aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/django.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4404c8368d..2be815df9b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -10,6 +10,9 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
+;;; Copyright © 2024 Wojtek Kosior <koszko@koszko.org>
+;;; Additions and modifications by Wojtek Kosior are additionally
+;;; dual-licensed under the Creative Commons Zero v1.0.
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1407,6 +1410,35 @@ to ElasticSearch.")
@code{CIDR} fields for use in Django projects.")
(license license:bsd-3)))
+(define-public python-django-timezone-field
+ (package
+ (name "python-django-timezone-field")
+ (version "6.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mfogel/django-timezone-field")
+ (commit version)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0hsl8fi6rv4yz973b7m7j8id0prswz3gxljjqclswpz9q35rc5mx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Some test dependencies are not packaged yet.
+ (list #:tests? #f))
+ (propagated-inputs (list python-django))
+ (native-inputs (list python-poetry-core python-pytest-django))
+ (home-page "https://pypi.org/project/django-timezone-field/")
+ (synopsis
+ "A Django app providing DB, form, and REST framework fields for zoneinfo
+and pytz timezone objects.")
+ (description
+ "This package provides a Django app providing DB, form, and REST
+framework fields for zoneinfo and pytz timezone objects.")
+ (license license:bsd-2)))
+
(define-public python-django-url-filter
(package
(name "python-django-url-filter")