aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 04e92b7cbf..5b4b2be904 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17597,6 +17597,17 @@ corresponding Evil keys.")
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-shell
+ ;; Setting the SHELL environment variable is required for the tests
+ ;; to find sh.
+ (lambda _
+ (setenv "SHELL" (which "sh"))
+ #t)))
+ #:tests? #t
+ #:test-command '("make" "test")))
(home-page "https://github.com/mamapanda/evil-traces")
(synopsis "Visual hints for @code{evil-ex}")
(description "This package adds visual hints to certain @code{ex}