aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a91ee8fe06..46a93f88af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4727,6 +4727,32 @@ makes available functions for visualization and exploration of the data and
results.")
(license license:gpl3+)))
+(define-public r-dss
+ (package
+ (name "r-dss")
+ (version "2.46.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "DSS" version))
+ (sha256
+ (base32
+ "1qm0pq6495fn2zrbddaadb1w01ry76rg8mmbmxf3zws9pww48jgf"))))
+ (properties `((upstream-name . "DSS")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-biocparallel r-bsseq))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/DSS")
+ (synopsis "Dispersion shrinkage for sequencing data")
+ (description
+ "DSS is an R library performing differential analysis for count-based
+sequencing data. It detects @dfn{differentially expressed genes} (DEGs) from
+RNA-seq, and differentially methylated loci or regions (DML/DMRs) from
+@dfn{bisulfite sequencing} (BS-seq). The core of DSS is a dispersion
+shrinkage method for estimating the dispersion parameter from Gamma-Poisson or
+Beta-Binomial distributions.")
+ ;; Any version of the GPL
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-bluster
(package
(name "r-bluster")
ages cross-base).Marius Bakke This makes sure it is inherited by packages using (cross-gcc ...). This commit is a followup to 01e8263febb9634564b4b73af49b81a36567a11b. * gnu/build/cross-toolchain.scm (cross-gcc-build-phases): Move 'treat-glibc-as-system-header' phase ... * gnu/packages/cross-base.scm (cross-gcc-arguments): ... here. 2019-02-09gnu: Use GCC 7 as the default compiler.Marius Bakke * gnu/packages/cross-base.scm (%gcc-cross-include-paths): Remove CROSS_C_INCLUDE_PATH & co in favor of CROSS_CPATH. * gnu/build/cross-toolchain.scm (%gcc-cross-include-paths): Likewise. (cross-gcc-build-phases): Set CROSS_C_INCLUDE_PATH and CROSS_CPLUS_INCLUDE_PATH when building the cross GCC. * gnu/packages/commencement.scm (libstdc++): Add "--disable-libstdcxx-dual-abi" to #:configure-flags. (gcc-boot0)[arguments]: Add "--disable-libmpx" to #:configure-flags. (gcc-final): Add phase to set C_INCLUDE_PATH and CPLUS_INCLUDE_PATH before building GCC. (gcc-toolchain-5): Use MAKE-GCC-TOOLCHAIN. (gcc-toolchain-7): Change to GCC-TOOLCHAIN. * gnu/packages/gcc.scm (gcc): Change from GCC-5 to GCC-7. (gfortran): Change to GFORTRAN-7. (gcc-objc): Change to GCC-OBJC-7. (gcc-objc++): Change to GCC-OBJC++-7. * gnu/packages/rust.scm (rust-1.19.0)[native-search-paths]: Change from C_INCLUDE_PATH & co to CPATH. 2018-03-23gnu: cross-base: Use invoke in (gnu build cross-toolchain).Mark H Weaver * gnu/build/cross-toolchain.scm (set-cross-path/mingw, install-strip): Use invoke. 2016-12-07gnu: cross-base: Move phases to (gnu build cross-toolchain).Ludovic Courtès * gnu/packages/cross-base.scm (cross-gcc-arguments) <#:phases>: Use 'cross-gcc-build-phases', and move body cross-toolchain.scm. (cross-gcc): Add #:imported-modules. Add (gnu build cross-toolchain) to #:modules. * gnu/build/cross-toolchain.scm: New file, with code from 'cross-gcc-arguments'. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.