aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7b2a0e4dd5..d65211779c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,7 +124,9 @@ AC_ARG_WITH([libgcrypt-prefix],
LIBGCRYPT_LIBDIR="$withval/lib"
;;
esac],
- [LIBGCRYPT="libgcrypt"])
+ [LIBGCRYPT="libgcrypt"
+ LIBGCRYPT_PREFIX="no"
+ LIBGCRYPT_LIBDIR="no"])
AC_ARG_WITH([libgcrypt-libdir],
[AS_HELP_STRING([--with-libgcrypt-libdir=DIR],
@@ -141,6 +143,9 @@ AC_ARG_WITH([libgcrypt-libdir],
esac],
[if test "x$LIBGCRYPT" = x; then
LIBGCRYPT="libgcrypt"
+ fi
+ if test "x$LIBGCRYPT_LIBDIR" = x; then
+ LIBGCRYPT_LIBDIR="no"
fi])
dnl Library name suitable for `dynamic-link'.
ils.scm?id=d838e7029854d8517c0c5b631f6042a925c86a81'>search-paths: Export 'string-tokenize*'....Ludovic Courtès 2015-05-04search-paths: Add 'evaluate-search-paths', from (guix scripts package)....Ludovic Courtès 2014-10-05utils: Add 'strip-keyword-arguments'....Ludovic Courtès 2014-07-20guix: utils: Add fold-tree and fold-tree-leaves....Eric Bavier 2014-04-14offload: '{send,receive}-files' wait for completion of the transfer....Ludovic Courtès 2014-04-07tests: Avoid buffering in 'fcntl-flock' tests....Ludovic Courtès 2014-03-24utils: Add 'call-with-decompressed-port' and 'call-with-compressed-output-port'....Ludovic Courtès 2014-03-24utils: Add 'filtered-output-port' and 'compressed-output-port'....Ludovic Courtès 2014-03-22utils: Add 'decompressed-port' and 'compressed-port'....Ludovic Courtès 2014-03-22utils: 'filtered-port' doesn't leave dangling processes behind....Ludovic Courtès 2014-03-08utils: Add a non-blocking option for 'fcntl-flock'....Ludovic Courtès 2014-03-06tests: Rewrite 'fcntl-lock' test....Ludovic Courtès 2014-01-24utils: Add 'fcntl-flock'....Ludovic Courtès 2013-11-13utils: Add 'string-replace-substring'....Ludovic Courtès 2013-08-23utils: Add `guile-version>?', and use it....Ludovic Courtès 2013-08-22substitute-binary: Try hard to avoid port buffering....Ludovic Courtès 2013-05-15substitute-binary: Pass `filtered-port' an unbuffered port....Ludovic Courtès 2013-05-12Move record utilities to (guix records)....Ludovic Courtès 2013-04-30Merge branch 'core-updates'Ludovic Courtès 2013-04-29substitute-binary: Support decompression from non-file ports....Ludovic Courtès 2013-04-28utils: Add `string-tokenize*'....Ludovic Courtès 2013-04-14utils: Add `fold2'....Ludovic Courtès 2013-02-01Augment `.dir-locals.el'....Ludovic Courtès 2013-01-23define-record-type*: Add the `thunked' field definition keyword....Ludovic Courtès 2013-01-06Update license headers....Ludovic Courtès 2012-12-05tests: Remove hard-coded /nix/store....Ludovic Courtès 2012-11-11Move base32 code to (guix base32)....Ludovic Courtès 2012-11-04utils: Add `package-name->name+version'....Ludovic Courtès 2012-11-01store: Add `store-path-package-name'....Ludovic Courtès 2012-08-30define-record-type*: Add the `inherit' syntactic constructor keyword....Ludovic Courtès 2012-08-14build: Pass $(NIX_INSTANTIATE) to the build and test environments....Ludovic Courtès 2012-07-03define-record-type*: Add `letrec*' behavior....Ludovic Courtès 2012-06-27Add `define-record-type*'....Ludovic Courtès 2012-06-11Add a `%current-system' fluid....Ludovic Courtès 2012-06-09Add `base16-string->bytevector'....Ludovic Courtès 2012-06-09Add `base32-string->bytevector' and `nix-base32-string->bytevector'....Ludovic Courtès 2012-06-03Fix `bytevector->nix-base32-string'....Ludovic Courtès 2012-06-01Add (guix utils), with `bytevector->base32-string'....Ludovic Courtès