aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emacs/guix-backend.el3
1 files changed, 2 insertions, 1 deletions
diff --git a/emacs/guix-backend.el b/emacs/guix-backend.el
index 6537888685..a320eae35a 100644
--- a/emacs/guix-backend.el
+++ b/emacs/guix-backend.el
@@ -206,7 +206,8 @@ this address (it should be defined by
;; A mix of the code from `geiser-repl--start-repl' and
;; `geiser-repl--to-repl-buffer'.
(let ((impl 'guile)
- (geiser-guile-load-path (list guix-load-path))
+ (geiser-guile-load-path (cons guix-load-path
+ geiser-guile-load-path))
(geiser-repl-startup-time guix-repl-startup-time))
(with-current-buffer buffer
(geiser-repl-mode)
ad'>diff --git a/etc/disarchive-manifest.scm b/etc/disarchive-manifest.scm
index 41f64eae4f..3dbfa356df 100644
--- a/etc/disarchive-manifest.scm
+++ b/etc/disarchive-manifest.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021-2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021-2024 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +35,8 @@
(and (origin-hash origin)
(or (string-suffix? ".tar.gz" file)
(string-suffix? ".tgz" file)
+ (string-suffix? ".tar.bz2" file)
+ (string-suffix? ".tbz2" file)
(string-suffix? ".tar.xz" file)
(string-suffix? ".tar" file))))))
diff --git a/etc/git/gitconfig b/etc/git/gitconfig
index 654a630b18..9c7827ced2 100644
--- a/etc/git/gitconfig
+++ b/etc/git/gitconfig
@@ -20,6 +20,7 @@
[b4]
attestation-check-dkim = off
attestation-policy = off
+ shazam-am-flags = --signoff --3way
linkmask = https://yhetil.org/guix/%s
linktrailermask = https://yhetil.org/guix/%s
midmask = https://yhetil.org/guix/%s
diff --git a/etc/news.scm b/etc/news.scm
index ffb483fea0..3e8c88499f 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -19,6 +19,7 @@
;; Copyright © 2021, 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;; Copyright © 2024 Oleg Pykhalov <go.wigust@gmail.com>
+;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;
;; Copying and distribution of this file, with or without modification, are
;; permitted in any medium without royalty provided the copyright notice and
@@ -27,6 +28,18 @@
(channel-news
(version 0)
+ (entry (commit "10a193596368443f441077525ebbddf787d91e4b")
+ (title
+ (en "Linux-libre 4.14 removed due to end of upstream support")
+ (de "Linux-libre 4.14 wurde entfernt"))
+ (body
+ (en "The linux-libre 4.14 kernel series has reached the end of
+ its life, and is no longer supported upstream. For this
+ reason, it has been removed from GNU Guix.")
+ (de "Die @code{linux-libre} 4.14-Versionsreihe hat ihr
+Supportende erreicht und wird nicht mehr unterstützt („end of life“). Daher ist die
+Versionsreihe aus GNU Guix entfernt worden.")))
+
(entry (commit "519e1e3eb88ec532fc83ebb742d9919269b57c87")
(title
(de "Neue Option @samp{--max-layers=N} für den Befehl @command{guix pack}")
diff --git a/etc/teams.scm b/etc/teams.scm
index 894636bb33..e2da31a2b4 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -8,7 +8,7 @@ exec $pre_inst_env_maybe guix repl -- "$0" "$@"
!#
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
@@ -176,6 +176,13 @@ and the r-build-system."
"guix/scripts/import/cran.scm"
"tests/cran.scm")))
+(define-team sugar
+ (team 'sugar
+ #:name "Sugar team"
+ #:description
+ "Everything related to the Sugar Desktop and learning environment."
+ #:scope (list "gnu/packages/sugar.scm")))
+
(define-team telephony
(team 'telephony
#:name "Telephony team"
@@ -299,10 +306,12 @@ asdf-build-system."
(define-team go
(team 'go
#:name "Go team"
- #:scope (list "gnu/packages/golang.scm"
- "gnu/packages/golang-check.scm"
- "guix/build/go-build-system.scm"
+ #:scope (list "gnu/packages/configuration-management.scm"
+ "gnu/packages/golang(-.+|)\\.scm$"
+ "gnu/packages/syncthing.scm"
+ "gnu/packages/terraform.scm"
"guix/build-system/go.scm"
+ "guix/build/go-build-system.scm"
"guix/import/go.scm"
"guix/scripts/import/go.scm"
"tests/go.scm")))
@@ -495,7 +504,8 @@ asdf-build-system."
and Thunderbird."
#:scope (list "gnu/build/icecat-extension.scm"
"gnu/packages/browser-extensions.scm"
- "gnu/packages/gnuzilla.scm")))
+ "gnu/packages/gnuzilla.scm"
+ "gnu/packages/tor-browsers.scm")))
(define-team racket
(team 'racket
@@ -592,7 +602,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Efraim Flashner"
"efraim@flashner.co.il")
- embedded bootstrap julia rust science)
+ embedded bootstrap julia rust)
(define-member (person "jgart"
"jgart@dismail.de")
@@ -624,7 +634,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Ricardo Wurmus"
"rekado@elephly.net")
- r core mentors tex)
+ core mentors r sugar tex)
(define-member (person "Christopher Baines"
"guix@cbaines.net")
@@ -710,6 +720,10 @@ GLib/GIO, GTK, GStreamer and Webkit."
"w@wmeyer.eu")
kernel)
+(define-member (person "Mark H Weaver"
+ "mhw@netris.org")
+ mozilla)
+
(define (find-team name)
(or (hash-ref %teams (string->symbol name))