aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bootstrap.scm5
-rw-r--r--gnu/packages/cross-base.scm4
2 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 315e8cf21e..e617093fb3 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -156,6 +156,11 @@ check whether everything is alright."
(cond ((string=? system "x86_64-linux") "/lib/ld-linux-x86-64.so.2")
((string=? system "i686-linux") "/lib/ld-linux.so.2")
((string=? system "mips64el-linux") "/lib/ld.so.1")
+
+ ;; XXX: This one is used bare-bones, without a libc, so add a case
+ ;; here just so we can keep going.
+ ((string=? system "xtensa-elf") "no-ld.so")
+
(else (error "dynamic linker name not known for this system"
system))))
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 0a0272cf74..a91952daca 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -293,6 +293,10 @@ XBINUTILS and the cross tool chain."
(cross-binutils triplet)
(cross-libc triplet))))
+(define-public xgcc-xtensa
+ ;; Bare-bones Xtensa cross-compiler, used to build the Atheros firmware.
+ (cross-gcc "xtensa-elf"))
+
;; (define-public xgcc-armel
;; (let ((triplet "armel-linux-gnueabi"))
;; (cross-gcc triplet