aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9156655b30..553b1e30c4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4930,15 +4930,18 @@ deployments.")
(source
(origin
(method url-fetch)
- (uri "https://github.com/xinetd-org/xinetd/archive/xinetd-2-3-15.tar.gz")
- (patches (search-patches "xinetd-CVE-2013-4342.patch" "xinetd-fix-fd-leak.patch"))
+ (uri
+ (string-append "https://github.com/xinetd-org/xinetd/archive/xinetd-"
+ (string-join (string-split version #\.) "-") ".tar.gz"))
+ (patches (search-patches "xinetd-CVE-2013-4342.patch"
+ "xinetd-fix-fd-leak.patch"))
(sha256
(base32
"0k59x52cbzp5fw0n8zn0y54j1ps0x9b72y8k5grzswjdmgs2a2v2"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-loadavg")
- #:tests? #f )) ; no tests
+ #:tests? #f)) ; no tests
(home-page "https://github.com/xinetd-org/xinetd")
(synopsis "Internet services daemon")
(description "@code{xinetd}, a more secure replacement for @code{inetd},