aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm4
-rw-r--r--manifest.scm16
2 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9888be28e4..b1c7172db6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -493,10 +493,8 @@ $(prefix)/etc/openrc\n")))
("automake" ,automake)
("gettext" ,gettext-minimal)
("texinfo" ,texinfo)
- ("graphviz" ,graphviz) ;non-minimal for PDF support
+ ("graphviz" ,graphviz-minimal)
("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
- ("imagemagick" ,imagemagick) ;for 'make dist'
- ("perl" ,perl) ;for 'make dist'
("help2man" ,help2man)
("po4a" ,po4a-minimal)))
(inputs
diff --git a/manifest.scm b/manifest.scm
index 7e4d82c3a5..27e1d62566 100644
--- a/manifest.scm
+++ b/manifest.scm
@@ -24,11 +24,25 @@
;;
;; guix shell --pure -m manifest.scm hello ...
+(use-modules (guix packages))
+
(concatenate-manifests
- (list (package->development-manifest (specification->package "guix"))
+ (list (package->development-manifest
+ (let ((guix (specification->package "guix")))
+ (package/inherit guix
+ ;; Replace with non-minimal Graphviz for PDF support.
+ (native-inputs (modify-inputs (package-native-inputs guix)
+ (replace "graphviz"
+ (specification->package "graphviz")))))))
+
;; Extra packages used by unit tests.
(specifications->manifest (list "gnupg"))
+ ;; Packages needed for 'make dist' and 'make distcheck'.
+ (specifications->manifest
+ (list "imagemagick"
+ "perl"))
+
;; Useful extras for patches submission.
(specifications->manifest
(list "b4"