aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-16 19:48:24 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 19:06:37 +0200
commit9af235335e8f8baf7f434a76570a954999231879 (patch)
tree858696efeddc77df7fdcd81fe4eaaf55e724d8df
parent1003d62790c32a5bf33fb09de590bbe459fb39d7 (diff)
downloadguix-9af235335e8f8baf7f434a76570a954999231879.tar.gz
guix-9af235335e8f8baf7f434a76570a954999231879.zip
gnu: guix: Remove unnecessary dependencies.
This reverts 0fda0486523d67c2c464386c07a0c2800d8d8c20, instead moving the dependencies needed for ‘make dist’ to ‘manifest.scm’. Removing this extra dependencies make it simpler to build the ‘guix’ package in particular on less-capable systems like i586-gnu. * gnu/packages/package-management.scm (guix)[native-inputs]: Remove IMAGEMAGICK and PERL. Use GRAPHVIZ-MINIMAL instead of GRAPHVIZ. * manifest.scm: Use the full-blown ‘graphviz’ package; add ‘imagemagick’ and ‘perl’. Reported-by: Janneke Nieuwenhuizen <janneke@gnu.org> Change-Id: Ia9d05c699e3cc2f9a9235a67f8ec840c26b66a82
-rw-r--r--gnu/packages/package-management.scm4
-rw-r--r--manifest.scm16
2 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9888be28e4..b1c7172db6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -493,10 +493,8 @@ $(prefix)/etc/openrc\n")))
("automake" ,automake)
("gettext" ,gettext-minimal)
("texinfo" ,texinfo)
- ("graphviz" ,graphviz) ;non-minimal for PDF support
+ ("graphviz" ,graphviz-minimal)
("font-ghostscript" ,font-ghostscript) ;fonts for 'dot'
- ("imagemagick" ,imagemagick) ;for 'make dist'
- ("perl" ,perl) ;for 'make dist'
("help2man" ,help2man)
("po4a" ,po4a-minimal)))
(inputs
diff --git a/manifest.scm b/manifest.scm
index 7e4d82c3a5..27e1d62566 100644
--- a/manifest.scm
+++ b/manifest.scm
@@ -24,11 +24,25 @@
;;
;; guix shell --pure -m manifest.scm hello ...
+(use-modules (guix packages))
+
(concatenate-manifests
- (list (package->development-manifest (specification->package "guix"))
+ (list (package->development-manifest
+ (let ((guix (specification->package "guix")))
+ (package/inherit guix
+ ;; Replace with non-minimal Graphviz for PDF support.
+ (native-inputs (modify-inputs (package-native-inputs guix)
+ (replace "graphviz"
+ (specification->package "graphviz")))))))
+
;; Extra packages used by unit tests.
(specifications->manifest (list "gnupg"))
+ ;; Packages needed for 'make dist' and 'make distcheck'.
+ (specifications->manifest
+ (list "imagemagick"
+ "perl"))
+
;; Useful extras for patches submission.
(specifications->manifest
(list "b4"