aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/serialization.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 71fae465d8..b85c507d64 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -271,7 +271,23 @@ that implements both the msgpack and msgpack-rpc specifications.")
"01gxn7kc8pzyh4aadjxxzq8cignmbwmm9rfrsmgqfg9w2q75dn74"))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'dont-install-gtest-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion
+ (string-append out "/include")
+ (delete-file-recursively "gtest")
+ (delete-file-recursively "gmock"))
+ (with-directory-excursion
+ (string-append out "/lib")
+ (for-each (lambda (file)
+ (delete-file file))
+ '("libgmock.so" "libgmock_main.so"
+ "libgtest.so" "libgtest_main.so"))))
+ #t)))))
(native-inputs
`(("python" ,python)))
(home-page "https://github.com/jbeder/yaml-cpp")
gnu/build/file-systems.scm?id=9c0a05b31edfdc31de09997f65d48e6a7f0f3747'>file-systems: iso9660-uuid->string: Use "-" as separator in the result....Danny Milosavljevic 2017-06-11file-systems: Handle EIO error in 'ENOENT-safe' as well....Adam Van Ymeren 2017-06-10file-systems: Provide string->ext*-uuid, string->btrfs-uuid....Danny Milosavljevic 2017-06-09file-systems: Provide string->iso9660-uuid....Danny Milosavljevic 2017-06-07file-systems: Use creation time if modification time is unset for ISO9660....Danny Milosavljevic 2017-06-03file-systems: Improve error handling in the iso9660 case - fixes boot problem....Danny Milosavljevic 2017-05-31file-systems: Improve error reporting....Danny Milosavljevic 2017-05-31gnu: build: Improve comments....Danny Milosavljevic 2017-05-27gnu: build: Improve docstrings....Danny Milosavljevic 2017-05-03gnu: build: file-systems: Add ISO-9660....Danny Milosavljevic 2017-04-13file-systems: Allow for bind-mounts of named sockets....Ludovic Courtès 2017-04-11build: Fix compilation warnings....Mathieu Othacehe 2017-03-01file-systems: Add FAT32 support....David Craven 2017-01-31file-systems: Do not read superblocks past the end of a device....Ludovic Courtès 2017-01-10system: Add btrfs file system support....David Craven 2017-01-10file-systems: Refactor file-system predicates....David Craven 2017-01-10file-systems: Refactor check-file-system....David Craven 2017-01-06file-systems: Refactor file system detection logic....David Craven 2016-11-29gnu: Allow nfs file systems to be automatically mounted....John Darrington 2016-11-06gnu: build: file-system: Change url of LUKS specification....ng0 2016-10-27file-systems: 'disk-partitions' detected partitions from mapped devices....Ludovic Courtès 2016-09-05file-systems: Always use (guix build syscalls)....Ludovic Courtès 2016-04-17file-systems: Add 'find-partition-by-luks-uuid'....Ludovic Courtès 2016-04-17file-systems: Separate ENOENT catching from ext2 superblock reads....Ludovic Courtès 2016-02-08file-systems: Spawn a Bournish REPL upon fsck failure....Ludovic Courtès 2016-01-01system: Allow the root file system to be named by UUID....Ludovic Courtès 2016-01-01file-systems: Move 'string->uuid' to the build side....Ludovic Courtès 2015-10-17file-systems: Do not truncate mount points that already exist....Ludovic Courtès 2015-08-08build: file-systems: Allow for bind mounting regular files....David Thompson 2015-07-14file-systems: Implement partition lookup by UUID....Ludovic Courtès 2015-07-14file-systems: Use (guix build syscalls) at build time if needed....Ludovic Courtès 2015-07-09build: file-systems: Import (guix build syscalls) for non-static Guiles....David Thompson