aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pdf.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 7f3dccc8ba..0882d3b942 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -184,6 +184,53 @@
Poppler PDF rendering library.")
(license license:lgpl2.1+)))
+(define-public python-poppler-qt5
+ (package
+ (name "python-poppler-qt5")
+ (version "0.24.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-poppler-qt5" version))
+ (sha256
+ (base32
+ "0l69llw1fzwz8y90q0qp9q5pifbrqjjbwii7di54dwghw5fc6w1r"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; There are no tests. The check phase just causes a rebuild.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "setup.py"
+ ;; This check always fails, so disable it.
+ (("if not check_qtxml\\(\\)")
+ "if True")
+ ;; Enable C++11, which is needed because of Qt5.
+ (("\\*\\*ext_args" line)
+ (string-append "extra_compile_args=['-std=gnu++11'], " line)))
+ ;; We need to pass an extra flag here. This cannot be in
+ ;; configure-flags because it should not be passed for the
+ ;; installation phase.
+ ((@@ (guix build python-build-system) call-setuppy)
+ "build_ext" (list (string-append "--pyqt-sip-dir="
+ (assoc-ref inputs "python-pyqt")
+ "/share/sip")) #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python-sip" ,python-sip)
+ ("python-pyqt" ,python-pyqt)
+ ("poppler-qt5" ,poppler-qt5)
+ ("qtbase" ,qtbase)))
+ (home-page "https://pypi.python.org/pypi/python-poppler-qt5")
+ (synopsis "Python bindings for Poppler-Qt5")
+ (description
+ "This package provides Python bindings for the Qt5 interface of the
+Poppler PDF rendering library.")
+ (license license:lgpl2.1+)))
+
(define-public libharu
(package
(name "libharu")
4459'>services: xorg: Fix typo in font path....* gnu/services/xorg.scm (xorg-start-command)[xserver.conf]: Fix typo in font path. Ludovic Courtès 2014-07-08services: Update to use the dmd 0.2 API....* gnu/services/avahi.scm (avahi-service)[start]: Wrap command in a list. * gnu/services/dbus.scm (dbus-service)[start]: Likewise. * gnu/services/ssh.scm (lsh-service): Likewise. * gnu/services/base.scm (mingetty-service)[start]: Likewise. (nscd-service)[start]: Likewise. (syslog-service)[start]: Likewise. (guix-service)[start]: Likewise. (udev-service)[start]: Use 'exec-command' instead of 'execl'. * gnu/services/xorg.scm (slim-service)[start]: Likewise, and use #:environment-variables. Ludovic Courtès 2014-05-18system: Make /run/current-system at activation time....* gnu/system.scm (etc-directory): Change default value of #:profile. Change contents of SHELLS. Use /run/current-system/profile/{s,}bin in BASHRC. (operating-system-boot-script)[%modules]: Add (guix build linux-initrd). Add call to 'activate-current-system' in gexp. (operating-system-initrd-file, operating-system-grub.cfg): New procedures. (operating-system-derivation): Don't build grub.cfg here and remove it from the file union. * gnu/system/vm.scm (qemu-image): Remove #:populate. (operating-system-build-gid, operating-system-default-contents): Remove. (system-qemu-image): Remove call to 'operating-system-default-contents'. Use 'operating-system-grub.cfg' to get grub.cfg. Add GRUB.CFG to #:inputs. (system-qemu-image/shared-store): Likewise, but don't add GRUB.CFG to #:inputs. (system-qemu-image/shared-store-script): Pass --system kernel option. * guix/build/activation.scm (%booted-system, %current-system): New variables. (boot-time-system, activate-current-system): New procedures. * guix/build/install.scm (evaluate-populate-directive): Add case for ('directory name uid gid mode). (directives, populate-root-file-system): New procedures. * guix/build/vm.scm (initialize-hard-disk): Replace calls to 'evaluate-populate-directive' by a call to 'populate-root-file-system'. * gnu/services/dmd.scm (dmd-configuration-file): Use /run/current-system/profile/bin. * gnu/services/xorg.scm (slim-service): Likewise. Ludovic Courtès 2014-05-11services: xorg: Fix harmless typo in slim.cfg....* gnu/services/xorg.scm (slim-service): Add missing whitespace in XINITRC invocation. Ludovic Courtès 2014-05-08services: Add service to cleanly unmount the root file system....* gnu/services/base.scm (root-file-system-service, user-processes-service): New procedures. (mingetty-service, nscd-service, syslog-service, guix-service): Add requirement on 'user-processes'. (%base-services): Add (user-processes-service) and (root-file-system-service). * gnu/services/xorg.scm (slim-service): Add requirement on 'user-processes'. Ludovic Courtès 2014-04-28services: xorg: Rewrite using gexps....* gnu/services/xorg.scm (xorg-start-command): Rewrite in terms of 'gexp->script'. (xinitrc): Likewise. Ludovic Courtès 2014-04-28services: Rewrite using gexps....* gnu/services.scm (<service>)[inputs]: Remove. * gnu/system.scm (links): Remove. (etc-directory): Add PASSWD and SHADOW to #:inputs. (operating-system-boot-script): Pass ETC to 'dmd-configuration-file'. (operating-system-derivation): Remove EXTRAS from the union. * gnu/system/linux.scm (pam-service->configuration): Rewrite in terms of 'gexp->derivation'. Compute the contents on the build side. Expect 'arguments' to contain a list of gexps. (pam-services->directory): Rewrite in terms of 'gexp->derivation'. (unix-pam-service): Change 'arguments' to a list of one gexp. * gnu/system/shadow.scm (<user-account>)[inputs]: Remove. [shell]: Change default value to a gexp. (passwd-file): Rewrite in terms of 'gexp->derivation'. Compute contents on the build side. * gnu/services/base.scm (host-name-service, mingetty-service, nscd-service, syslog-service, guix-service): Change 'start' and 'stop' to gexps; remove 'inputs' field. (guix-build-accounts): Change 'shell' field to a gexp. * gnu/services/networking.scm (static-networking-service): Change 'start' and 'stop' to gexps; remove 'inputs' field. * gnu/services/xorg.scm (slim-service): Likewise. * gnu/services/dmd.scm (dmd-configuration-file): Expect ETC to be a derivation. Change 'config' to a gexp. Use 'gexp->file' instead of 'text-file'. * doc/guix.texi (Defining Services): Update nscd example with gexps, and without 'inputs'. Add xref to "G-Expressions". Ludovic Courtès 2014-04-06services: slim: Use a system-wide xinitrc that defaults to wmaker....* gnu/services/xorg.scm (xinitrc): New procedure. (slim-service)[slim.cfg]: Use it as the 'login_cmd'. Ludovic Courtès 2014-02-19gnu: Introduce the (gnu services ...) modules....* gnu/system/dmd.scm: Remove file. Move contents to... * gnu/services.scm, gnu/services/base.scm, gnu/services/dmd.scm, gnu/services/networking.scm, gnu/services/xorg.scm: ... here. New files. * gnu/system.scm, gnu/system/vm.scm: Adjust accordingly. * guix/scripts/system.scm (%user-module): Likewise. * doc/guix.texi (Using the Configuration System): Likewise. (Defining Services): Likewise. Ludovic Courtès