aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/system.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 3524544746..3115714b08 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -314,3 +314,26 @@ files, which contain information about the IANA-assigned port, protocol, and
ONC RPC numbers")
(home-page "http://packages.debian.org/sid/netbase")
(license gpl2)))
+
+(define-public netcat
+ (package
+ (name "netcat")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/netcat/netcat-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1frjcdkhkpzk0f84hx6hmw5l0ynpmji8vcbaxg8h5k2svyxz0nmm"))))
+ (build-system gnu-build-system)
+ (home-page "http://netcat.sourceforge.net")
+ (synopsis "Read and write data over TCP/IP")
+ (description
+ "Netcat is a featured networking utility which reads and writes data
+across network connections, using the TCP/IP protocol. It is designed to be a
+reliable \"back-end\" tool that can be used directly or easily driven by other
+programs and scripts. At the same time, it is a feature-rich network debugging
+and exploration tool, since it can create almost any kind of connection you
+would need and has several interesting built-in capabilities.")
+ (license gpl2+)))
d>Tobias Geerinckx-Rice 2019-12-23gnu: knot: Update to 2.9.2....Tobias Geerinckx-Rice 2019-12-23gnu: knot-resolver: Update to 4.3.0 [fixes CVE-2019-19331]....Tobias Geerinckx-Rice 2019-12-19gnu: bind: Update to 9.14.9....Tobias Geerinckx-Rice 2019-12-04gnu: knot: Update to 2.9.1 [fixes CVE-2019-19331]....Leo Famulari 2019-12-03gnu: nsd: Update to 4.2.3....Tobias Geerinckx-Rice 2019-11-20gnu: bind: Update to 9.14.8 [fixes CVE-2019-6477]....Tobias Geerinckx-Rice 2019-11-11gnu: Add knot-resolver....宋文武 2019-10-29gnu: libasr: Update to 1.0.3....Tobias Geerinckx-Rice 2019-10-27gnu: unbound: Update to 1.9.4....Tobias Geerinckx-Rice 2019-10-27gnu: libasr: Don't use NAME in source URI....Tobias Geerinckx-Rice 2019-10-16gnu: bind: Update to 9.14.7 [fixes CVE-2019-6475 & CVE-2019-6476]....Tobias Geerinckx-Rice 2019-10-11gnu: knot: Update to 2.9.0....Tobias Geerinckx-Rice 2019-09-18gnu: bind: Update to 9.14.6 [fixes CVE-2019-6471]....Tobias Geerinckx-Rice 2019-09-17gnu: unbound: Update to 1.9.3....Tobias Geerinckx-Rice 2019-08-22gnu: nsd: Update to 4.2.2....Tobias Geerinckx-Rice 2019-08-22gnu: bind: Update to 9.14.5....Tobias Geerinckx-Rice 2019-07-28gnu: unbound: Update to 1.9.2....Rutger Helling 2019-07-18gnu: bind: Update to 9.14.4....Tobias Geerinckx-Rice 2019-06-20gnu: bind: Update to 9.14.3 [fixes CVE-2019-6471]....Tobias Geerinckx-Rice 2019-06-17gnu: nsd: Update to 4.2.0....Tobias Geerinckx-Rice 2019-06-17gnu: knot: Update to 2.8.2....Tobias Geerinckx-Rice 2019-05-16gnu: bind: Update to 9.14.2....Tobias Geerinckx-Rice 2019-04-24gnu: Add public-suffix-list....Chris Marusich 2019-04-25gnu: bind: Update to 9.12.4-P1 [fixes CVE-2018-5743, CVE-2019-6467]....Tobias Geerinckx-Rice 2019-04-22gnu: nsd: Update to 4.1.27....Tobias Geerinckx-Rice 2019-04-15gnu: knot: Update to 2.8.1....Tobias Geerinckx-Rice 2019-03-23gnu: bind: Return #T from all phases....Tobias Geerinckx-Rice 2019-03-20gnu: knot: Update to 2.8.0....Tobias Geerinckx-Rice