aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-science.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7b9d0cd7f6..63f11d9ca7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2178,18 +2178,20 @@ annotations on an existing boxplots and barplots generated by seaborn.")
(sha256
(base32 "00900bw24rxgcgwgxp9xlx0l5im96r1n5hn0r3mxvbdgc3lyyq48"))))
(build-system pyproject-build-system)
- ;; Astropy is an optional import, but we do not include it as it creates a
- ;; module cycle: astronomy->python-science->astronomy.
- (propagated-inputs (list python-h5py ; optional import
- python-matplotlib ; optional import
- python-numpy
- python-sympy))
;; Pint is optional, but we do not propagate it due to its size.
(native-inputs
(list python-pint
python-pytest
python-setuptools
+ python-setuptools-scm
python-wheel))
+ ;; Astropy is an optional import, but we do not include it as it creates a
+ ;; module cycle: astronomy->python-science->astronomy.
+ (propagated-inputs
+ (list python-h5py ; optional import
+ python-matplotlib ; optional import
+ python-numpy
+ python-sympy))
(home-page "https://unyt.readthedocs.io")
(synopsis "Library for working with data that has physical units")
(description