aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 30e895eee6..c986a9f354 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5419,10 +5419,23 @@ interfaces and the standard higher-level merlin protocol.")
(arguments '(#:package "dot-merlin-reader"
#:tests? #f)) ; no tests
(propagated-inputs (list ocaml-merlin-lib))
+ (properties `((ocaml5.0-variant . ,(delay ocaml5.0-dot-merlin-reader))))
(synopsis "Reads config files for @code{ocaml-merlin}")
(description "@code{ocaml-dot-merlin-reader} is an external reader for
@code{ocaml-merlin} configurations.")))
+(define-public ocaml5.0-dot-merlin-reader
+ (package-with-ocaml5.0
+ (package
+ (inherit ocaml-merlin-lib-500)
+ (name "ocaml-dot-merlin-reader")
+ (arguments '(#:package "dot-merlin-reader"
+ #:tests? #f)) ; no tests
+ (propagated-inputs (list ocaml5.0-merlin-lib))
+ (synopsis "Reads config files for @code{ocaml-merlin}")
+ (description "@code{ocaml-dot-merlin-reader} is an external reader for
+@code{ocaml-merlin} configurations."))))
+
(define-public ocaml-merlin
(package
(inherit ocaml-dot-merlin-reader)