aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/firmware.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index d07b329d26..054b674b23 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1447,3 +1447,21 @@ shortcuts and can be interpreted by your window managher. This layout only
makes use of the 42 keys that the Atreus also has for the main functionality.
See the @file{keyboards/atreus/keymaps/dvorak_42_key/keymap.c} source file for
the keymap definition."))
+
+(define-public qmk-udev-rules
+ (package
+ (inherit qmk-firmware-ergodox-ez-default)
+ (name "qmk-udev-rules")
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("./util/udev" "lib/udev/rules.d"
+ #:include-regexp ("rules$")))))
+ (native-inputs '())
+ (inputs '())
+ (propagated-inputs '())
+ (synopsis "Udev rules for QMK Firmware")
+ (description
+ "This package provides a set of udev rules to specify the proper
+privileges for flashing QMK compatible devices without needing root. The
+rules require the group @code{plugdev} to be added to each user that needs
+this.")))
>Tobias Geerinckx-Rice 2020-11-23gnu: mujs: Fetch sources from git....* gnu/packages/javascript.scm (mujs)[source]: GIT-FETCH the sources directly from the author. [arguments]: Add VERSION to #:make-flags. Tobias Geerinckx-Rice 2020-11-16gnu: quickjs: Update to 2020-11-08....* gnu/packages/javascript.scm (quickjs): Update to 2020-11-08. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Ryan Prior 2020-09-14gnu: Add quickjs....* gnu/packages/javascript.scm (quickjs): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Ryan Prior 2020-09-02gnu: js-filesaver: Also install unminified version....* gnu/packages/javascript.scm (js-filesaver)[arguments]: Add phase to install unminified javascript file. Efraim Flashner