aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/patches/xpra-6.1-install_libs.patch (renamed from gnu/packages/patches/xpra-6.0-install_libs.patch)10
-rw-r--r--gnu/packages/xorg.scm6
3 files changed, 9 insertions, 9 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a86bfddc86..8bec41ae5e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2267,7 +2267,7 @@ dist_patch_DATA = \
%D%/packages/patches/xplanet-1.3.1-libimage_gif.c.patch \
%D%/packages/patches/xplanet-1.3.1-xpUtil-Add2017LeapSecond.cpp.patch \
%D%/packages/patches/xpra-6.0-systemd-run.patch \
- %D%/packages/patches/xpra-6.0-install_libs.patch \
+ %D%/packages/patches/xpra-6.1-install_libs.patch \
%D%/packages/patches/xsane-fix-memory-leak.patch \
%D%/packages/patches/xsane-fix-pdf-floats.patch \
%D%/packages/patches/xsane-fix-snprintf-buffer-length.patch \
diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.1-install_libs.patch
index c608b519f4..0ec2aee288 100644
--- a/gnu/packages/patches/xpra-6.0-install_libs.patch
+++ b/gnu/packages/patches/xpra-6.1-install_libs.patch
@@ -4,19 +4,19 @@ This workaround for Gentoo interferes with our use of --no-compile during
the 'install stage.
diff --git a/setup.py b/setup.py
-index 4f066fa8bf..14a9ed65ed 100755
+index be7a3758e8..28dc1be191 100755
--- a/setup.py
+++ b/setup.py
-@@ -760,8 +760,6 @@ if modules_ENABLED:
+@@ -953,8 +953,6 @@ if modules_ENABLED:
# Utility methods for building with Cython
- def do_add_cython_ext(*args, **kwargs):
+ def do_add_cython_ext(*args, **kwargs) -> None:
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
- return
if not cython_ENABLED:
raise ValueError(f"cannot build {args}: cython compilation is disabled")
if cython_tracing_ENABLED:
-@@ -1971,9 +1969,6 @@ else:
+@@ -2175,9 +2173,6 @@ else:
if root_prefix.endswith("/usr"):
# ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
root_prefix = root_prefix[:-4]
@@ -26,7 +26,7 @@ index 4f066fa8bf..14a9ed65ed 100755
print(f" root_prefix={root_prefix!r}")
build_xpra_conf(root_prefix)
-@@ -2116,13 +2111,6 @@ else:
+@@ -2320,13 +2315,6 @@ else:
if uinput_ENABLED:
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6b953ef152..6825474a6a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6158,7 +6158,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "6.0.2")
+ (version "6.1.0")
(source
(origin
(method git-fetch)
@@ -6167,9 +6167,9 @@ basic eye-candy effects.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "176qxrksgr07jhrlny3zxybnvf091kxkfmfnv9ci3h2k1nbwqh2x"))
+ (base32 "1x1ld2p3q47irqq6p1b3rd9ffbi7kvgxyvfmgi0skfin17b2aqx4"))
(patches (search-patches "xpra-6.0-systemd-run.patch"
- "xpra-6.0-install_libs.patch"))))
+ "xpra-6.1-install_libs.patch"))))
(build-system python-build-system)
(inputs
(list bash-minimal ; for wrap-program