aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index aa8c0352b6..c5408f8627 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6138,6 +6138,67 @@ definition lists, tables, and other features. A compatibility mode is
provided for those who need a drop-in replacement for Markdown.pl.")
(license license:gpl2+)))
+;; This is the last version of Pandoc 1.x, which is preferred for Rmarkdown.
+(define-public ghc-pandoc-1
+ (package (inherit ghc-pandoc)
+ (version "1.19.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/pandoc/pandoc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0mim429mpakrcnm50csxyqk3ljcx2l26r5grk6w9isnggwgqrq5v"))))
+ (arguments
+ `(#:configure-flags (list "--allow-newer=skylighting")))
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson-for-pandoc-1)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-cmark" ,ghc-cmark)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-deepseq-generics" ,ghc-deepseq-generics)
+ ("ghc-diff" ,ghc-diff)
+ ("ghc-doctemplates" ,ghc-doctemplates-for-pandoc-1)
+ ("ghc-executable-path" ,ghc-executable-path)
+ ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-filemanip" ,ghc-filemanip)
+ ("ghc-haddock-library" ,ghc-haddock-library)
+ ("ghc-hslua" ,ghc-hslua-for-pandoc-1)
+ ("ghc-http" ,ghc-http)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-juicypixels" ,ghc-juicypixels)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-network" ,ghc-network)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-old-time" ,ghc-old-time)
+ ("ghc-pandoc-types" ,ghc-pandoc-types-for-pandoc-1)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-random" ,ghc-random)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-sha" ,ghc-sha)
+ ("ghc-skylighting" ,ghc-skylighting-for-pandoc-1)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-tagsoup" ,ghc-tagsoup)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-texmath" ,ghc-texmath-for-pandoc-1)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-xml" ,ghc-xml)
+ ("ghc-yaml" ,ghc-yaml-for-pandoc-1)
+ ("ghc-zip-archive" ,ghc-zip-archive)
+ ("ghc-zlib" ,ghc-zlib)))
+ (native-inputs
+ `(("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))))
+
(define-public ghc-hs-bibutils
(package
(name "ghc-hs-bibutils")
td> 2017-02-13gnu: Add LibDOM.Eric Bavier * gnu/packages/web.scm (libdom): New variable. 2017-02-13gnu: Add perl-switch.Eric Bavier * gnu/packages/perl.scm (perl-switch): New variable. 2017-02-13gnu: Add libcss.Eric Bavier * gnu/packages/web.scm (libcss): New variable. 2017-02-13gnu: Add LibWapcaplet.Eric Bavier * gnu/packages/web.scm (libwapcaplet): New variable. 2017-02-13gnu: Add hubbub.Eric Bavier * gnu/packages/web.scm (hubbub): New variable. 2017-02-13gnu: Add libparserutils.Eric Bavier * gnu/packages/web.scm (netsurf-buildsystem) (netsurf-buildsystem-arguments, libparserutils): New variables. 2017-02-13gnu: utf8proc: Enable tests.Eric Bavier * gnu/packages/textutils.scm (utf8proc)[inputs]: New field. [arguments]: Remove '#:tests? #f'. Add check-data phase. 2017-02-13gnu: utf8proc: Upgrade to 2.1.0.Eric Bavier * gnu/packages/textutils.scm (utf8proc): Upgrade to 2.1.0. 2017-02-13gnu: netsurf: Upgrade to 3.6.Eric Bavier * gnu/packages/web.scm (netsurf): Upgrade to 3.6. [source]: 'https' -> 'http'. Remove modules, snippet, and patches. [home-page]: 'https' -> 'http'. [arguments]: Adjust source directories. * gnu/packages/patches/netsurf-about.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Remove it. 2017-02-14gnu: borg: Update to 1.0.10.Tobias Geerinckx-Rice * gnu/packages/backup.scm (borg): Update to 1.0.10. 2017-02-13gnu: libwacom: Update to 0.23.Marius Bakke * gnu/packages/xdisorg.scm (libwacom): Update to 0.23. 2017-02-13gnu: Add python-openid.Julien Lepiller * gnu/packages/python.scm (python-openid): New variable. 2017-02-13gnu: gajim: Do not propagate Python packages.Ricardo Wurmus * gnu/packages/messaging.scm (gajim)[propagated-inputs]: Move all inputs from here... [inputs]: ...to here. 2017-02-13gnu: gajim: Update to 0.16.7.Ricardo Wurmus * gnu/packages/messaging.scm (gajim): Update to 0.16.7. 2017-02-13gnu: ffmpeg: Build with SDL support.Arun Isaac SDL is required for the `ffplay' executable to be built. * gnu/packages/video.scm (ffmpeg)[inputs]: Add sdl2. Signed-off-by: Marius Bakke <mbakke@fastmail.com> 2017-02-13gnu: libuv: Update to 1.11.0.Marius Bakke * gnu/packages/libevent.scm (libuv): Update to 1.11.0. [home-page]: Change to new home. 2017-02-13gnu: libev: Update to 4.24.Marius Bakke * gnu/packages/libevent.scm (libev): Update to 4.24. 2017-02-13gnu: Add font-google-material-design-icons.José Miguel Sánchez García * gnu/packages/font.scm (font-google-material-design-icons): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2017-02-13gnu: Add simh.José Miguel Sánchez García * gnu/packages/simh.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add simh.scm. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2017-02-13gnu: Add ghc-hslogger.rsiddharth * gnu/packages/haskell.scm (ghc-hslogger): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2017-02-13gnu: ghc: remove unused 'libedit' inputSergei Trofimovich ghc stopped using libedit (via editline) in 2009: https://git.haskell.org/ghc.git/commitdiff/46aed8a4a084add708bbd119d19905105d5f0d72 * gnu/packages/haskell.scm (ghc, ghc-8): remove 'libedit' input Signed-off-by: Sergei Trofimovich <slyfox@inbox.ru> Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2017-02-13gnu: bundler: Update to 1.14.4.Ben Woodcroft * gnu/packages/ruby.scm (bundler): Update to 1.14.4. 2017-02-13system: Use the normalized codeset for the locale name in the examples.Ludovic Courtès * gnu/system/examples/bare-bones.tmpl <locale>: Change to "en_US.utf8". * gnu/system/examples/desktop.tmpl <locale>: Likewise. * gnu/system/examples/lightweight-desktop.tmpl <locale>: Likewise. 2017-02-12gnu: wget: Update to 1.19.1.Marius Bakke * gnu/packages/wget.scm (wget): Update to 1.19.1. 2017-02-12gnu: i3status: Update to 2.11.Marius Bakke * gnu/packages/wm.scm (i3status): Update to 2.11. 2017-02-12gnu: Add angband.Christopher Allan Webber * gnu/packages/games.scm (angband): New variable. 2017-02-12gnu: postgresql: Update to 9.5.6.Leo Famulari * gnu/packages/databases.scm (postgresql): Update to 9.5.6. 2017-02-12gnu: mcabber: Update to 1.0.5 [fixes CVE-2017-5604].Leo Famulari * gnu/packages/messaging.scm (mcabber): Update to 1.0.5. 2017-02-12gnu: screen: Fix CVE-2017-5618.Leo Famulari * gnu/packages/patches/screen-CVE-2017-5618.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/screen.scm (screen)[source]: Use it. 2017-02-12gnu: mpd: Update to 0.20.4.Leo Famulari * gnu/packages/mpd.scm (mpd): Update to 0.20.4. [native-inputs]: Add gcc-5. 2017-02-12gnu: qemu: Fix CVE-2017-{5667,5898,5931}.Leo Famulari * gnu/packages/patches/qemu-CVE-2017-5667.patch, gnu/packages/patches/qemu-CVE-2017-5898.patch, gnu/packages/patches/qemu-CVE-2017-5931.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. gnu/packages/qemu.scm (qemu)[source]: Use them. 2017-02-12gnu: ffmpeg@2.8: Update to 2.8.11.Efraim Flashner * gnu/packages/video.scm (ffmpeg@2.8): Update to 2.8.11. 2017-02-12gnu: ffmpeg: Update to 3.2.4.Efraim Flashner * gnu/packages/video.scm (ffmpeg): Update to 3.2.4. 2017-02-12services: Add openvswitch-service-type.宋文武 * gnu/services/networking.scm (<openvswitch-configuration>): New record type. (openvswitch-activation, openvswitch-shepherd-service): New procedures. (openvswitch-service-type): New variable. * doc/guix.texi (Networking Services): Document it. 2017-02-12gnu: Add openvswitch.宋文武 * gnu/packages/networking.scm (openvswitch): New variable. 2017-02-11gnu: irssi: Update to 1.0.1.Leo Famulari * gnu/packages/irc.scm (irssi): Update to 1.0.1.