aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm31
1 files changed, 11 insertions, 20 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7c12ebf6d2..d438525ac4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2078,14 +2078,11 @@ capabilities.")
(define-public python2-numpy
(let ((numpy (package-with-python2 python-numpy)))
(package (inherit numpy)
- ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is customized for
- ;; Python 2. Since it is also an input to PYTHON2-MATPLOTLIB, we need to
- ;; import the right version of 'matplotlib' as well.
- (inputs `(("python2-numpydoc" ,python2-numpydoc)
- ("python2-matplotlib" ,python2-matplotlib)
- ,@(alist-delete "python-numpydoc"
- (alist-delete "python-matplotlib"
- (package-inputs numpy))))))))
+ ;; Make sure we use exactly PYTHON2-MATPLOTLIB, which is customized for
+ ;; Python 2.
+ (inputs `(("python2-matplotlib" ,python2-matplotlib)
+ ,@(alist-delete "python-matplotlib"
+ (package-inputs numpy)))))))
(define-public python-pyparsing
(package
@@ -2289,19 +2286,15 @@ toolkits.")
(define-public python2-matplotlib
(let ((matplotlib (package-with-python2 python-matplotlib)))
(package (inherit matplotlib)
- ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is
- ;; customized for Python 2.
+ ;; Make sure to use special packages for Python 2 instead
+ ;; of those automatically rewritten by package-with-python2.
(propagated-inputs
`(("python2-pycairo" ,python2-pycairo)
("python2-pygobject-2" ,python2-pygobject-2)
,@(alist-delete "python-pycairo"
(alist-delete "python-pygobject"
(package-propagated-inputs
- matplotlib)))))
- (inputs
- `(("python2-numpydoc" ,python2-numpydoc)
- ,@(alist-delete "python-numpydoc"
- (package-inputs matplotlib)))))))
+ matplotlib))))))))
(define-public python-scipy
(package
@@ -2819,11 +2812,9 @@ computing.")
(package (inherit ipython)
;; Make sure we use custom python2-NAME packages.
(inputs
- `(("python2-numpydoc" ,python2-numpydoc)
- ("python2-matplotlib" ,python2-matplotlib)
- ,@(alist-delete "python-numpydoc"
- (alist-delete "python-matplotlib"
- (package-inputs ipython))))))))
+ `(("python2-matplotlib" ,python2-matplotlib)
+ ,@(alist-delete "python-matplotlib"
+ (package-inputs ipython)))))))
(define-public python-isodate
(package