aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 046730b39e..bb8a922d53 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1015,7 +1015,12 @@ It can also be used for ahead-of-time code generation for building standalone
compilers. The just-in-time (jit) part of the name is now something of a
misnomer.")))
-(define-public libgccjit (make-libgccjit gcc-9))
+(define-public libgccjit-9 (make-libgccjit gcc-9))
+(define-public libgccjit-10 (make-libgccjit gcc-10))
+(define-public libgccjit-11 (make-libgccjit gcc-11))
+(define-public libgccjit-12 (make-libgccjit gcc-12))
+
+(define-public libgccjit libgccjit-10)
(define (make-gccgo gcc)
"Return a gccgo package based on GCC."
:40:54 +0100'>2023-01-09daemon: Improve error message for wrong hash sizes....Ludovic Courtès 2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès 2022-10-17Revert "nix: Guard against removing temporary roots of living processes."...Ludovic Courtès 2022-10-07nix: Guard against removing temporary roots of living processes....Ludovic Courtès 2022-09-11daemon: Remove unused function findOutput....Maxime Devos 2022-09-11daemon: Remove unused function exportPaths....Maxime Devos 2022-09-11daemon: Remove unused function openStore....Maxime Devos 2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice 2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice 2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org 2022-04-14daemon: Support systemd-style socket activation....Ludovic Courtès 2022-01-18daemon: Always default to gzip for log compression....Ludovic Courtès 2021-11-27daemon: Print the line whence we expect an integer....Tobias Geerinckx-Rice 2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès 2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès 2021-11-19daemon: Micro-optimize 'deletePath'....Ludovic Courtès 2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès