aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde.scm79
1 files changed, 39 insertions, 40 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 1f734071cd..609716a0ad 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -412,40 +412,40 @@ projects.")
(define-public kdevelop
(package
(name "kdevelop")
- (version "23.04.3")
+ (version "24.05.2")
(source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kdevelop-" version ".tar.xz"))
- (sha256
- (base32 "0m1q5nhx7wd4b8850ikw7dk6zka57gapf78wawjv2h1hijxcyf4v"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kdevelop-" version ".tar.xz"))
+ (sha256
+ (base32 "10z53ri4g3b199cv9394pflgdlcnr9y2gh7xr4isl2kpn26jiwh0"))))
(build-system qt-build-system)
(native-inputs
(list extra-cmake-modules pkg-config shared-mime-info qttools-5))
(inputs (list boost
clang
grantlee
- karchive
- kcmutils
- kcrash
- kdeclarative
- kdoctools
- kguiaddons
- ki18n
- kiconthemes
- kio ;; not checked as requirement
- kitemmodels
- kitemviews
- kjobwidgets
- knotifications
- knotifyconfig
- kparts
- kservice
- ksyntaxhighlighting
- ktexteditor
- kwindowsystem
- kxmlgui
+ karchive-5
+ kcmutils-5
+ kcrash-5
+ kdeclarative-5
+ kdoctools-5
+ kguiaddons-5
+ ki18n-5
+ kiconthemes-5
+ kio-5 ;; not checked as requirement
+ kitemmodels-5
+ kitemviews-5
+ kjobwidgets-5
+ knotifications-5
+ knotifyconfig-5
+ kparts-5
+ kservice-5
+ ksyntaxhighlighting-5
+ ktexteditor-5
+ kwindowsystem-5
+ kxmlgui-5
libkomparediff2
breeze-icons
qtbase-5
@@ -453,30 +453,29 @@ projects.")
qtquickcontrols-5 ;; not checked as requirement
qtquickcontrols2-5 ;; not checked as requirement
qtwebengine-5
- threadweaver
+ threadweaver-5
;; recommendes
astyle
kdevelop-pg-qt
- libksysguard
;; optional
apr ; required for subversion support
apr-util ; required for subversion support
- attica
- kconfigwidgets
- knewstuff
- krunner
+ attica-5
+ kconfigwidgets-5
+ knewstuff-5
+ krunner-5
;; TODO: OktetaGui, OktetaKastenControllers
plasma-framework
;; TODO: purpose
- sonnet
+ sonnet-5
subversion))
- ;; run-time packages - TODO
- ;; ClazyStandalone
- ;; Cppcheck
- ;; heaptrack
- ;; heaptrack_gui
- ;; meson
+ ;; run-time packages - TODO
+ ;; ClazyStandalone
+ ;; Cppcheck
+ ;; heaptrack
+ ;; heaptrack_gui
+ ;; meson
(arguments
(list #:tests? #f ;; there are some issues with the test suite
#:phases