aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tree-sitter.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index e9b76733a7..5774fe8adc 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -365,3 +365,13 @@ will be used in description and synopsis."
"021vnbpzzb4cca3ncd4qhzy583vynhndn3qhwayxrpgdl61m44i6"
"0.20.1"
#:grammar-directories '("ocaml" "interface")))
+
+(define-public tree-sitter-php
+ ;; There are a lot of additions, the last tag was placed more than 1 year ago
+ (let ((commit "f860e598194f4a71747f91789bf536b393ad4a56")
+ (revision "0"))
+ (tree-sitter-grammar
+ "php" "PHP"
+ "02yc5b3qps8ghsmy4b5m5kldyr5pnqz9yw663v13pnz92r84k14g"
+ (git-version "0.19.0" revision commit)
+ #:commit commit)))
td>Mathieu Lirzin 2016-02-24Do not check package freshness during upgrade....Alex Kost 2015-12-20packages: Remove now redundant graph procedures....Ludovic Courtès 2015-10-21packages: Update 'check-package-freshness' to use (guix upstream)....Ludovic Courtès 2015-06-18Move 'specification->package+output' to (gnu packages)....Ludovic Courtès 2015-04-18packages: Allow package lookups with version prefixes....Ludovic Courtès 2015-04-08Merge branch 'master' into core-updates宋文武 2015-04-07gnu: Emit a warning when a package module cannot be loaded....Ludovic Courtès 2015-04-03packages: Fix typo....Alex Kost 2015-01-26gnu: Raise an error when a bootstrap binary is not found....Ludovic Courtès 2015-01-20gnu: 'search-patch' raises an error when a patch is not found....Ludovic Courtès 2015-01-03gnu: Search for patches under $GUIX_PACKAGE_PATH....Ludovic Courtès 2014-12-21packages: Sort Scheme file lists used by 'fold-packages'....Ludovic Courtès 2014-11-11gnu-maintenance: Introduce <gnu-release> data type....Ludovic Courtès 2014-09-29packages: Optimize 'find-packages-by-name' to avoid disk accesses....Ludovic Courtès 2014-09-24Introduce the 'GUIX_PACKAGE_PATH' environment variable....Ludovic Courtès 2014-09-24packages: Add '%package-module-search-path'....Ludovic Courtès 2014-09-24packages: Generalize package module search....Ludovic Courtès 2014-09-03Move specification->package to gnu/packages.scm....Cyril Roelandt 2014-08-20Move 'check-package-freshness' from 'guix package' to 'packages'....Alex Kost 2014-08-19packages: Remove dead code....Alex Kost 2014-07-20guix: refresh: Add --list-dependent option....Eric Bavier