aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index fca04e91c4..8afdf1a98c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -290,23 +290,17 @@ by calling @code{FrozenList.freeze}.")
(define-public python-aiosignal
(package
(name "python-aiosignal")
- (version "1.2.0")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiosignal" version))
(sha256
- (base32 "1wkxbdgw07ay8yzx3pg1jcm46p3d21rfb5g4k17ysz3vdkdngvbq"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "tests")))))))
+ (base32 "1z4cnqww6j0xl6f3vx2r6kfv1hdny1pnlll7difvfj8nbvhrdkal"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:test-flags #~(list "tests")))
(propagated-inputs (list python-frozenlist))
- (native-inputs (list python-pytest python-pytest-asyncio))
+ (native-inputs (list python-pytest python-pytest-asyncio python-pytest-cov))
(home-page "https://github.com/aio-libs/aiosignal")
(synopsis "Callback manager for Python @code{asyncio} projects")
(description "This Python module provides @code{Signal}, an abstraction to