aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8578789872..3bb49ff549 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -717,11 +717,11 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(modify-phases %standard-phases
(add-after 'install 'install-footprints ; from footprints tarball
(lambda* (#:key inputs outputs #:allow-other-keys)
- (zero? (system* "tar" "xvf"
- (assoc-ref inputs "kicad-footprints")
- "-C" (string-append (assoc-ref outputs "out")
- "/share/kicad/modules")
- "--strip-components=1"))))
+ (invoke "tar" "xvf"
+ (assoc-ref inputs "kicad-footprints")
+ "-C" (string-append (assoc-ref outputs "out")
+ "/share/kicad/modules")
+ "--strip-components=1")))
;; We change the default global footprint file, which is generated if
;; it doesn't exist in user's home directory, from the one using the
;; github plugin, to the one using the KISYSMOD environment path.
33'>gnu: Update kde frameworks to 5.34.0....Hartmut Goebel 2017-04-17gnu: Fix typos in descriptions....Tobias Geerinckx-Rice 2017-04-12gnu: kde-frameworks: No longer setenv CTEST_OUTPUT_ON_FAILURE....Hartmut Goebel 2017-04-12gnu: Update kde-frameworks to 5.32.0...Hartmut Goebel 2017-04-12gnu: Update phonon to 4.9.1...Hartmut Goebel 2017-03-22Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2017-03-20gnu: Add comments on why setting QT_QPA_PLATFORM for tests....Hartmut Goebel 2017-03-13Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2017-03-11gnu: Add phonon-backend-gstreamer....Thomas Danckaert 2017-03-11gnu: phonon: Install Qt extensions....Thomas Danckaert 2017-03-09Merge branch 'master' into core-updatesLudovic Courtès 2017-03-04gnu: kio: Fix CVE-2017-6410....Leo Famulari 2017-01-23Merge branch 'master' into core-updatesLudovic Courtès 2017-01-11gnu: kcrash: Work around race condition when starting Xvfb....Ludovic Courtès 2017-01-06Merge branch 'master' into core-updatesLeo Famulari 2016-12-19gnu: kdbusaddons: Embed kinit store dir, avoid dependency cycles....Thomas Danckaert 2016-12-02gnu: flex: Update to 2.6.2....David Craven