aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm29
-rw-r--r--gnu/packages/golang.scm28
2 files changed, 29 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e69a65c3da..cb8bc27021 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1386,6 +1386,35 @@ interfaces to back that API. Packages in the Go ecosystem can depend on it,
while callers can implement logging with whatever backend is appropriate.")
(license license:asl2.0)))
+(define-public go-github-com-go-task-slim-sprig
+ (let ((commit "afa1e2071829e4db655eb448d6c7c16eb0bc5766")
+ (revision "0"))
+ (package
+ (name "go-github-com-go-task-slim-sprig")
+ (version (git-version "2.20.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-task/slim-sprig")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1185y8qygv8gb3wpghx5d945wq68j4dbaiffq3h0dh453g4h1w7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Tests try to access the network.
+ #:tests? #f
+ #:import-path "github.com/go-task/slim-sprig"))
+ (home-page "https://github.com/go-task/slim-sprig")
+ (synopsis "Various useful template functions for Go")
+ (description
+ "Sprig provides over 100 functions that extend the Go template system.
+Slim-Sprig is a fork of Sprig that removes all external dependencies to make
+the library more lightweight.")
+ (license license:expat))))
+
(define-public go-github-com-gobwas-glob
(package
(name "go-github-com-gobwas-glob")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aeb205571c..5b473810cd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6863,34 +6863,6 @@ maps (because they are not addressable using Go reflection).")
template functions.")
(license license:expat)))
-(define-public go-github-com-go-task-slim-sprig
- (let ((commit "afa1e2071829e4db655eb448d6c7c16eb0bc5766")
- (revision "0"))
- (package
- (name "go-github-com-go-task-slim-sprig")
- (version (git-version "2.20.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/go-task/slim-sprig")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1185y8qygv8gb3wpghx5d945wq68j4dbaiffq3h0dh453g4h1w7a"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/go-task/slim-sprig"
- ;; Tests try to access the network.
- #:tests? #f))
- (home-page "https://github.com/go-task/slim-sprig")
- (synopsis "Various useful template functions for Go")
- (description
- "Sprig provides over 100 functions that extend the Go template system.
-Slim-Sprig is a fork of Sprig that removes all external dependencies to make
-the library more lightweight.")
- (license license:expat))))
-
(define-public go-github-com-bmatcuk-doublestar
(package
(name "go-github-com-bmatcuk-doublestar")