aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm43
1 files changed, 35 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 311b7c36a7..85bdbc04ac 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2527,29 +2527,32 @@ AsyncSeek if the inner type does.")
(description "This library provides async executors.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-async-global-executor-1
+(define-public rust-async-global-executor-2
(package
(name "rust-async-global-executor")
- (version "1.4.3")
+ (version "2.0.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "async-global-executor" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "017s1lik153s587l6q9x5bf9i1n7gxqcg3zn2mdgvf16rm4rn1vk"))))
+ (base32 "1xjacr43sbz2zk0zygpd9k14n95wa61x8n9i8mcdwdkz659fr1lm"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-async-executor" ,rust-async-executor-1)
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-async-channel" ,rust-async-channel-1)
+ ("rust-async-executor" ,rust-async-executor-1)
("rust-async-io" ,rust-async-io-1)
+ ("rust-async-mutex" ,rust-async-mutex-1)
+ ("rust-blocking" ,rust-blocking-1)
("rust-futures-lite" ,rust-futures-lite-1)
("rust-num-cpus" ,rust-num-cpus-1)
("rust-once-cell" ,rust-once-cell-1)
+ ("rust-tokio" ,rust-tokio-1)
("rust-tokio" ,rust-tokio-0.2)
- ("rust-tokio" ,rust-tokio-0.3))
- #:cargo-development-inputs
- (("rust-doc-comment" ,rust-doc-comment-0.3))))
+ ("rust-tokio" ,rust-tokio-0.3))))
(home-page "https://github.com/async-rs/async-global-executor")
(synopsis "Global executor built on top of @code{async-executor} and
@code{async-io}")
@@ -2558,6 +2561,30 @@ AsyncSeek if the inner type does.")
@code{async-executor} and @code{async-io}.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-async-global-executor-1
+ (package
+ (inherit rust-async-global-executor-2)
+ (name "rust-async-global-executor")
+ (version "1.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "async-global-executor" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "017s1lik153s587l6q9x5bf9i1n7gxqcg3zn2mdgvf16rm4rn1vk"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-async-executor" ,rust-async-executor-1)
+ ("rust-async-io" ,rust-async-io-1)
+ ("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-tokio" ,rust-tokio-0.3))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3))))))
+
(define-public rust-async-io-1
(package
(name "rust-async-io")