aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/messaging.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 20bdb713b5..919ae6aaa7 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -29,7 +29,7 @@
;;; Copyright © 2020, 2021 Robert Karszniewicz <avoidr@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
@@ -1726,20 +1726,24 @@ of the most common use cases is to define avatars for MUC rooms.")))
(define-public c-toxcore
(package
(name "c-toxcore")
- (version "0.2.12")
+ (version "0.2.19")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/TokTok/c-toxcore")
- (commit (string-append "v" version))))
+ (commit (string-append "v" version))
+ ;; XXX: c-toxcore now depends on a package called 'cmp', an
+ ;; implementation of MessagePack in C. Fetch the submodule
+ ;; for now, maybe package it later.
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "0a6sqpm00d2rn0nviqfz4gh9ck1wzci6rxgmqmcyryl5ca19ffvp"))))
+ "0wq6grc5lfjip39gm0ji1cw6b1sdv1zvimg1g40haqzhj51755za"))))
(arguments
- `(#:tests? #f)) ; FIXME: Testsuite seems to stay stuck on test 3. Disable
- ; for now.
+ (list #:tests? #f ; figure out how to run the tests
+ #:configure-flags #~(list "-DENABLE_STATIC=false")))
(build-system cmake-build-system)
(native-inputs
(list pkg-config))