aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3eaf956d73..0caf741715 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -311,6 +311,9 @@ GhcWithHscBuiltViaC=YES
")))
(invoke "./configure"
"--enable-hc-boot" ; boot from C "source" files
+ ;; Embed the absolute file name of GCC 2.95 in the GHC
+ ;; driver script.
+ (string-append "--with-gcc=" (which "gcc"))
(string-append "--prefix=" #$output)
(string-append "--build=" build)
(string-append "--host=" build))))