aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ebfd298938..e5fd71ef1b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -100,6 +100,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages search)
#:use-module (gnu packages shells)
#:use-module (gnu packages ssh)
#:use-module (gnu packages statistics)
@@ -3161,6 +3162,36 @@ reStructuredText.")
(define-public python2-pygments
(package-with-python2 python-pygments))
+(define-public python-sphinxcontrib-websupport
+ (package
+ (name "python-sphinxcontrib-websupport")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-websupport" version))
+ (sha256
+ (base32
+ "1f9f0wjpi9nhikbyaz6d19s7qvzdf1nq2g5dsh640fma4q9rd1bs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-xapian-bindings" ,python-xapian-bindings)))
+ ;; Needed for running the test suite
+ (native-inputs
+ `(("python-six" ,python-six)
+ ("python-jinja2" ,python-jinja2)
+ ("python-docutils" ,python-docutils)
+ ("python-sphinx" ,python-sphinx)
+ ("python-sqlalchemy" ,python-sqlalchemy)
+ ("python-whoosh" ,python-whoosh)))
+ (home-page "http://sphinx-doc.org/")
+ (synopsis "Sphinx API for web applications")
+ (description "This package provides a Python API to easily integrate
+Sphinx documentation into your web application. It provides tools to
+integrate Sphinx documents in web templates and to handle searches.")
+ (license license:bsd-3)))
+
(define-public python-sphinx
(package
(name "python-sphinx")
ers/…/start returned error: failed to start shim: exec: \"containerd-shim\": executable file not found in $PATH: unknown"'. * gnu/services/docker.scm (containerd-shepherd-service): Add "containerd-shim" to PATH. Oleg Pykhalov 2020-09-23services: docker: Fix configuration....This is a follow-up to e04b90607ac903359c90c9bad1b67fb7ce2f0eb6. * gnu/services/docker.scm (docker-shepherd-service): Fix "enable-proxy?" configuration. Oleg Pykhalov 2020-09-21services: Docker: Fix typo in configuration....This is a follow-up to f0a09310e6ff2ed63770cb585c551ba94ce4a9d0. * gnu/services/docker.scm (docker-shepherd-service): Properly reference variables in service definition. Efraim Flashner 2020-09-21services: docker: Fix enable-proxy? option....The userland proxy option does not properly disable the userland proxy when set to false. Docker defaults to enabling the userland proxy if the option is unset on the command line. * gnu/services/docker.scm (docker-shepherd-service): Properly handle the 'enable-proxy?' option. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Jesse Dowell 2020-09-15services: docker: Fix service definition....This commit follows a404716d411cf7cd49ff02e3100f0bbf6622d6d5. * gnu/services/docker.scm (docker-configuration)[docker-cli]: New record field. (docker-service-type): Use this. * doc/guix.texi (Miscellaneous Services)[Docker Service]: Document this. Oleg Pykhalov 2020-09-14services: docker: Fix service definition....This is a follow-up to 8422a67dc16af4dd5eb82180463aa7a0b362d5b9. * gnu/services/docker.scm (docker-service-type): Use a composed list for packages in profile-service-type. Efraim Flashner 2020-09-14services: docker: Make docker command available....* gnu/services/docker.scm (docker-service-type): Extend the profile-service-type and add the docker-cli package. Efraim Flashner 2020-08-16services: docker: Add 'enable-iptables?' argument....* gnu/services/docker.scm (docker-configuration): Define the argument. * gnu/services/docker.scm (docker-shepherd-service): Use it. * doc/guix.texi (Docker Service): Document it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Alexey Abramov 2020-06-03gnu: services: docker: Add a debug? parameter....* gnu/services/docker.scm (docker-configuration): Add a debug? field. (containerd-shepherd-service): Pass the "--log-level=debug" argument when DEBUG? is true. (docker-shepherd-service): Pass the "--debug" and "--log-level=debug" arguments when DEBUG? is true. * doc/guix.texi (Miscellaneous Services): Update doc. Maxim Cournoyer 2020-04-27file-systems: mount the PID cgroup filesystem....* gnu/system/file-systems.scm (%control-groups): Add "pids". * gnu/services/docker.scm (docker-shepherd-service): Resolve a TODO. This has allowed me to make a specific configuration of nsjail work. Jakub Kądziołka