aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ipfs.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 82ef0ea028..a67919691f 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -218,17 +218,27 @@ written in Go.")
(version "0.4.18")
(source
(origin
- (method url-fetch)
+ (method url-fetch/tarbomb)
(uri (string-append
"https://dist.ipfs.io/go-ipfs/v" version
"/go-ipfs-source.tar.gz"))
(sha256
(base32
- "19hfgbyn5sr1bw0cwm3gsjz0w3b3vh3mmkax1906raah30lavj1x"))))
+ "19hfgbyn5sr1bw0cwm3gsjz0w3b3vh3mmkax1906raah30lavj1x"))
+ (file-name (string-append name "-" version "-source"))))
(build-system go-build-system)
(arguments
'(#:unpack-path "github.com/ipfs/go-ipfs"
- #:import-path "github.com/ipfs/go-ipfs/cmd/ipfs"))
+ #:import-path "github.com/ipfs/go-ipfs/cmd/ipfs"
+ #:phases (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure .gz files are writable so that the
+ ;; 'reset-gzip-timestamps' phase can do its work.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))
+ #t))))))
(home-page "https://ipfs.io")
(synopsis "Go implementation of IPFS, a peer-to-peer hypermedia protocol")
(description "IPFS is a global, versioned, peer-to-peer filesystem. It
a href='/guix/commit/THANKS?id=51310642049c1e16e8f65e8acaae9775303b75db'>Thank Bruno.Ludovic Courtès 2014-11-13doc: Improve acknowledgments....* doc/guix.texi (Acknowledgments): Expound a bit. * THANKS: Mention artwork; thank Felipe & Nikita. Ludovic Courtès 2014-11-11Thank Sylvain.Ludovic Courtès 2014-11-10Thank Philip Woods.Ludovic Courtès 2014-11-08Thank Felipe.Ludovic Courtès 2014-08-31Thank Frederico.Ludovic Courtès 2014-08-23Thank Brandon.Ludovic Courtès 2014-08-15Update AUTHORS and THANKS.Ludovic Courtès 2014-07-22Thank Adam.Ludovic Courtès 2014-07-18Thank Marek.Ludovic Courtès 2014-07-16Update 'THANKS'....* THANKS: Correct the email address I use for Guix work. John Darrington 2014-07-05Thank Taylan and Alex.Ludovic Courtès 2014-06-17Thank Benno.Ludovic Courtès 2014-06-09Thank Carlos.Ludovic Courtès 2014-01-03Thank Niels.Ludovic Courtès 2013-12-30Thank Kete.Ludovic Courtès 2013-10-14Thank Jeffrin and David.Ludovic Courtès 2013-10-06Update 'AUTHORS'....* AUTHORS: Add Alex, Joshua, and Aljosha. Ludovic Courtès 2013-09-21Thank Cyrill.Ludovic Courtès 2013-09-12Thank Matthias and Yutaka.Ludovic Courtès 2013-08-24gnu: Add pspp....* gnu/packages/maths.scm (pspp): New variable. * THANKS: Thank John Darrington for help with debugging. Andreas Enge 2013-08-24gnu: Add libextractor....* gnu/packages/gnunet.scm: New module. * gnu-system.am (GNU_SYSTEM_MODULES): Add module. * THANKS: Thank Christian Grothoff for help with debugging. Andreas Enge 2013-07-15Thank the translators.Ludovic Courtès 2013-07-04Import (guix hash) in build-aux/download.scm....* build-aux/download.scm: Import (guix hash). Reported by Matthew Lien <bluet@bluet.org>. Ludovic Courtès