aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ccd9ad57cf..279c06294e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -994,6 +994,8 @@ extensive documentation, including API reference and a tutorial.")
(base32
"04k942gn8vl95kwf0qskkv6npclfm31d78ljkrkgyqxxcni1w76d"))))
(build-system gnu-build-system)
+ (outputs '("out"
+ "doc")) ;13 MiB of gtk-doc HTML
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -1006,6 +1008,13 @@ extensive documentation, including API reference and a tutorial.")
(arguments
`(#:tests? #f
#:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-gtk-doc-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install documentation to "doc".
+ (let ((doc (assoc-ref outputs "doc")))
+ (substitute* "docs/Makefile.in"
+ (("TARGET_DIR = \\$\\(datadir\\)")
+ (string-append "TARGET_DIR = " doc))))))
(add-after 'configure 'fix-codegen
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "pygtk-codegen-2.0"