aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mpi.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 4d2458344f..baf6ce11e0 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -247,6 +247,12 @@ bind processes, and much more.")
"--enable-openib-rdmacm"
"--enable-openib-rdmacm-ibaddr"
+ ;; Enable support for the 'Process Management
+ ;; Interface for Exascale' (PMIx) used e.g. by
+ ;; Slurm for the management communication and
+ ;; coordination of MPI processes.
+ "--with-pmix=internal"
+
;; Enable support for SLURM's Process Manager
;; Interface (PMI).
,(string-append "--with-pmi="