aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/networking.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0d6de040e5..e3486ffadc 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -927,7 +927,7 @@ private (reserved).")
(define-public perl-socket6
(package
(name "perl-socket6")
- (version "0.28")
+ (version "0.29")
(source
(origin
(method url-fetch)
@@ -937,7 +937,7 @@ private (reserved).")
".tar.gz"))
(sha256
(base32
- "11j5jzqbzmwlws9zals43ry2f1nw9qy6im7yhn9ck5rikywrmm5z"))))
+ "054izici8klfxs8hr5rljib28plijpsfymy99xbzdp047bx1b2a6"))))
(build-system perl-build-system)
(arguments
`(#:phases
atic) (for-each (lambda (lib) (link lib (string-append static "/" (basename lib))) (delete-file lib)) (find-files source "\\.a$")))))))) (synopsis "Perl Compatible Regular Expressions") (description "The PCRE library is a set of functions that implement regular expression pattern matching using the same syntax and semantics as Perl 5. PCRE has its own native API, as well as a set of wrapper functions that correspond to the POSIX regular expression API.") (license license:bsd-3) (home-page "https://www.pcre.org/"))) (define-public pcre2 (package (name "pcre2") (version "10.42") (source (origin (method url-fetch) (uri (string-append "https://github.com/PCRE2Project/pcre2" "/releases/download/pcre2-" version "/pcre2-" version ".tar.bz2")) (sha256 (base32 "0h78np8h3dxlmvqvpnj558x67267n08n9zsqncmlqapans6csdld")))) (build-system gnu-build-system) (outputs '("out" "static")) (inputs (list bzip2 readline zlib)) (arguments (list #:configure-flags #~'("--enable-unicode" "--enable-pcre2grep-libz" "--enable-pcre2grep-libbz2" "--enable-pcre2test-libreadline" "--enable-pcre2-16" "--enable-pcre2-32" ;; riscv64-linux is an unsupported architecture. #$@(if (target-riscv64?) #~() #~("--enable-jit"))) #:phases #~(modify-phases %standard-phases (add-after 'unpack 'patch-paths (lambda _ (substitute* "RunGrepTest" (("/bin/echo") (which "echo"))))) (add-after 'install 'move-static-libs (lambda _ (let ((source (string-append #$output "/lib")) (static (string-append #$output:static "/lib"))) (mkdir-p static) (for-each (lambda (lib) (link lib (string-append static "/" (basename lib))) (delete-file lib)) (find-files source "\\.a$")))))))) (synopsis "Perl Compatible Regular Expressions") (description "The PCRE library is a set of functions that implement regular expression pattern matching using the same syntax and semantics as Perl 5. PCRE has its own native API, as well as a set of wrapper functions that correspond to the POSIX regular expression API.") (license license:bsd-3) (home-page "https://www.pcre.org/")))