aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/gnutls.scm3
-rw-r--r--gnu/packages/patches/gnutls-server-name-fix.patch17
3 files changed, 20 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 2d2eb0631f..52c834318b 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -344,6 +344,7 @@ dist_patch_DATA = \
gnu/packages/patches/glibc-ldd-x86_64.patch \
gnu/packages/patches/gnunet-fix-scheduler.patch \
gnu/packages/patches/gnunet-fix-tests.patch \
+ gnu/packages/patches/gnutls-server-name-fix.patch \
gnu/packages/patches/gobject-introspection-cc.patch \
gnu/packages/patches/grub-gets-undeclared.patch \
gnu/packages/patches/gstreamer-0.10-bison3.patch \
diff --git a/gnu/packages/gnutls.scm b/gnu/packages/gnutls.scm
index c7f379cc07..3e4fa631d9 100644
--- a/gnu/packages/gnutls.scm
+++ b/gnu/packages/gnutls.scm
@@ -74,7 +74,8 @@ specifications.")
"/gnutls-" version ".tar.xz"))
(sha256
(base32
- "1krx33ab2ijwfz71f1ba8labxfsic7jhlhv6rvjsyw566jj9a3d2"))))
+ "1krx33ab2ijwfz71f1ba8labxfsic7jhlhv6rvjsyw566jj9a3d2"))
+ (patches (list (search-patch "gnutls-server-name-fix.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/gnutls-server-name-fix.patch b/gnu/packages/patches/gnutls-server-name-fix.patch
new file mode 100644
index 0000000000..01f0b761e0
--- /dev/null
+++ b/gnu/packages/patches/gnutls-server-name-fix.patch
@@ -0,0 +1,17 @@
+Fix a typo introduced in the first series implementing
+'set-session-server-name!' whereby the trailing nul character would
+be passed on the wire, thereby breaking connections.
+
+diff --git a/guile/src/core.c b/guile/src/core.c
+index 82fd573..2778205 100644
+--- a/guile/src/core.c
++++ b/guile/src/core.c
+@@ -719,7 +719,7 @@ SCM_DEFINE (scm_gnutls_set_session_server_name_x, "set-session-server-name!",
+ c_name = scm_to_locale_string (name);
+
+ err = gnutls_server_name_set (c_session, c_type, c_name,
+- strlen (c_name) + 1);
++ strlen (c_name));
+ free (c_name);
+
+ if (EXPECT_FALSE (err != GNUTLS_E_SUCCESS))