aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 06942a3647..466f13631c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 raingloom <raingloom@riseup.net>
;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Fries <fries1234@protonmail.com>
@@ -2576,6 +2577,32 @@ Use waterutil with it to work with TUN/TAP packets/frames.")
"@{gitconfig} is a package to get configuration values from gitconfig.")
(license license:expat)))
+(define-public go-github-com-spf13-cobra
+ (package
+ (name "go-github-com-spf13-cobra")
+ (version "1.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spf13/cobra")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mhnqfgcwwcknlhk7n07i02q3iqq6ihksj4dwz296zci8ry3w0d0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/spf13/cobra"))
+ (propagated-inputs
+ (list go-github-com-spf13-pflag))
+ (home-page "https://github.com/spf13/cobra")
+ (synopsis "Go library for creating CLI applications")
+ (description
+ "Cobra is both a library for creating powerful modern CLI applications as
+well as a program to generate applications and command files.")
+ (license license:asl2.0)))
+
(define-public go-github-com-stathat-go
(let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1b138d8d0e..39d98afb45 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3674,31 +3674,6 @@ containers.")
(description "Safe and easy casting from one type to another in Go")
(license license:expat)))
-(define-public go-github-com-spf13-cobra
- (package
- (name "go-github-com-spf13-cobra")
- (version "1.8.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spf13/cobra")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mhnqfgcwwcknlhk7n07i02q3iqq6ihksj4dwz296zci8ry3w0d0"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/spf13/cobra"))
- (propagated-inputs
- (list go-github-com-spf13-pflag))
- (home-page "https://github.com/spf13/cobra")
- (synopsis "Go library for creating CLI applications")
- (description "Cobra is both a library for creating powerful modern CLI
-applications as well as a program to generate applications and command files.")
- (license license:asl2.0)))
-
(define-public go-github-com-spf13-jwalterweatherman
(package
(name "go-github-com-spf13-jwalterweatherman")