aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f978a42c84..53ea3e53bb 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -712,14 +712,14 @@ Guile's foreign function interface.")
(define-public haunt
(package
(name "haunt")
- (version "0.1")
+ (version "0.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://files.dthompson.us/haunt/haunt-"
+ (uri (string-append "https://files.dthompson.us/haunt/haunt-"
version ".tar.gz"))
(sha256
(base32
- "15q1qwjnay7k90ppqrzqsmikvwyj61mjvf1zahyd9gm4vi2fgb3x"))))
+ "1id83n8fs7jxys1d8jy70vylg8gzcvlw1y7hb41y3qxv5zi4671m"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 match) (ice-9 ftw)
@@ -743,8 +743,13 @@ Guile's foreign function interface.")
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
(,modules)))
#t)))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
(inputs
`(("guile" ,guile-2.0)))
+ (propagated-inputs
+ `(("guile-reader" ,guile-reader)))
(synopsis "Functional static site generator")
(description "Haunt is a static site generator written in Guile
Scheme. Haunt features a functional build system and an extensible
f.scm, gnu/packages/emacs.scm, gnu/packages/emulators.scm, gnu/packages/engineering.scm, gnu/packages/enlightenment.scm, gnu/packages/finance.scm, gnu/packages/fltk.scm, gnu/packages/fontutils.scm, gnu/packages/freedesktop.scm, gnu/packages/game-development.scm, gnu/packages/games.scm, gnu/packages/geo.scm, gnu/packages/gl.scm, gnu/packages/glib.scm, gnu/packages/gnome.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/graph.scm, gnu/packages/graphics.scm, gnu/packages/graphviz.scm, gnu/packages/gtk.scm, gnu/packages/ham-radio.scm, gnu/packages/image-processing.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/irc.scm, gnu/packages/jrnl.scm, gnu/packages/julia.scm, gnu/packages/kde-frameworks.scm, gnu/packages/key-mon.scm, gnu/packages/libffi.scm, gnu/packages/libreoffice.scm, gnu/packages/libusb.scm, gnu/packages/lirc.scm, gnu/packages/logging.scm, gnu/packages/machine-learning.scm, gnu/packages/mail.scm, gnu/packages/mate.scm, gnu/packages/maths.scm, gnu/packages/medical.scm, gnu/packages/messaging.scm, gnu/packages/monitoring.scm, gnu/packages/mp3.scm, gnu/packages/mpd.scm, gnu/packages/music.scm, gnu/packages/networking.scm, gnu/packages/nutrition.scm, gnu/packages/openldap.scm, gnu/packages/openstack.scm, gnu/packages/package-management.scm, gnu/packages/password-utils.scm, gnu/packages/patchutils.scm, gnu/packages/pdf.scm, gnu/packages/photo.scm, gnu/packages/polkit.scm, gnu/packages/protobuf.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/qt.scm, gnu/packages/rdf.scm, gnu/packages/ruby.scm, gnu/packages/search.scm, gnu/packages/selinux.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/simulation.scm, gnu/packages/ssh.scm, gnu/packages/statistics.scm, gnu/packages/storage.scm, gnu/packages/sync.scm, gnu/packages/terminals.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/tryton.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/virtualization.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wicd.scm, gnu/packages/xdisorg.scm, gnu/packages/xorg.scm: Update module references. 2019-01-09Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner 2019-01-03gnu: bullet: Update to 2.88.Efraim Flashner * gnu/packages/game-development.scm (bullet): Update to 2.88. [source]: Use 'git-fetch'. Add snippet to remove bundled binaries and libraries. [arguments]: Add configure-flags to prevent building demos. Add custom 'remove-failing-tests phase to skip tests which fail after removing bundled code. 2019-01-01gnu: allegro@5.0: Fix building with newer mesa.Efraim Flashner * gnu/packages/game-development.scm (allegro@5.0)[source]: Add patch. (allegro)[patch]: Rename patch file. * gnu/packages/patches/allegro-fix-compiliation-mesa-18.2.5-and-later.patch: Rename to gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch. * gnu/local.mk (dist_patch_DATA): Register it. 2019-01-01gnu: allegro@4: Fix building with newer mesa.Efraim Flashner * gnu/packages/game-development.scm (allegro@4)[source]: Add patch. * gnu/packages/patches/allegro4-mesa-18.2.5-and-later.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. 2018-12-12gnu: allegro: Fix compilation with Mesa >= 18.2.5.Rutger Helling * gnu/packages/game-development.scm (allegro)[source]: Add allegro-fix-compilation-mesa-18.2.5-and-later.patch. * gnu/packages/patches/allegro-fix-compilation-mesa-18.2.5-and-later.patch: New file. 2018-11-16gnu: tiled: Update to 1.2.1.David Thompson * gnu/packages/game-development.scm (tiled): Update to 1.2.1. 2018-11-11gnu: tiled: Fetch sources from git.Ricardo Wurmus * gnu/packages/game-development.scm (tiled)[source]: Fetch from git. 2018-10-25gnu: sfml: Update to 2.5.1.Tobias Geerinckx-Rice * gnu/packages/game-development.scm (sfml): Update to 2.5.1. 2018-10-25gnu: sfml: Don't use unstable tarball.Tobias Geerinckx-Rice * gnu/packages/game-development.scm (sfml)[source]: Use GIT-FETCH and GIT-FILE-NAME. 2018-10-11gnu: godot: Update to 3.0.6.Brett Gilio * gnu/packages/game-development.scm (godot): Update to 3.0.6. 2018-10-03gnu: tiled: Update to 1.2.0.David Thompson * gnu/packages/game-development.scm (tiled): Update to 1.2.0. 2018-10-03gnu: guile-chickadee: Update to 0.3.0.宋文武 * gnu/packages/game-development.scm (guile-chickadee): Update to 0.3.0. [arguments]: Add 'patch-godir' phase.