aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 17b4941bc4..7110b9b898 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4016,17 +4016,6 @@ recurrence relations.")
(sha256
(base32 "00s2rwjdlq38zkf7wl1gvm2aw057r30266lkzfxkrfzr4i705xnq"))))
(build-system pyproject-build-system)
- (propagated-inputs
- (list python-importlib-metadata
- python-ndim
- python-numpy
- python-sympy))
- (native-inputs (list ;python-cplot ;only used in deselected tests
- python-matplotx
- python-meshio
- python-meshzoo
- python-pytest
- python-scipy))
(arguments
(list
#:test-flags
@@ -4034,6 +4023,19 @@ recurrence relations.")
;; in calls to cplot.
#~(list "--deselect" "tests/test_u3.py::test_write_single"
"--deselect" "tests/test_u3.py::test_write_tree")))
+ (native-inputs
+ (list python-matplotx
+ python-meshio
+ python-meshzoo
+ python-pytest
+ python-scipy
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-importlib-metadata
+ python-ndim
+ python-numpy
+ python-sympy))
(home-page "https://github.com/diego-hayashi/orthopy")
(synopsis "Tools for orthogonal polynomials, Gaussian quadrature")
(description "@code{orthopy} provides various orthogonal polynomial
ests/nar.scm, tests/packages.scm, tests/pk-crypto.scm, tests/pki.scm, tests/profiles.scm, tests/publish.scm, tests/pypi.scm, tests/records.scm, tests/scripts-build.scm, tests/scripts.scm, tests/services.scm, tests/sets.scm, tests/size.scm, tests/snix.scm, tests/store.scm, tests/substitute.scm, tests/syscalls.scm, tests/system.scm, tests/ui.scm, tests/union.scm, tests/upstream.scm, tests/utils.scm: Don't exit at the end of test groups. * tests/containers.scm: Likewise. Use 'test-skip' instead of exiting with error code 77. Mathieu Lirzin