aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b30a35506a..1155affd3d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -587,6 +587,33 @@ structs. The approach is similar to how other marshallers work in Golang,
\"unmarshalling\" an instance of a grammar into a struct.")
(license license:expat)))
+(define-public go-github-com-alecthomas-repr
+ (package
+ (name "go-github-com-alecthomas-repr")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/repr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ikvl78dighkn87bxk6gki4wcz9f138n7kbqkagj5vbdb690yjkl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.18
+ #:import-path "github.com/alecthomas/repr"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/alecthomas/repr/")
+ (synopsis "Represent Go values in an almost direct form")
+ (description
+ "This package attempts to represent Go values in a form that can be used
+almost directly in Go source code.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-template
;; No release, see <https://github.com/alecthomas/template/issues/7>.
(let ((commit "a0175ee3bccc567396460bf5acd36800cb10c49c")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4db1e4184b..ba91abc6c9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6734,31 +6734,6 @@ other files). If stdout is not a terminal, colour formatting will be
stripped.")
(license license:expat)))
-(define-public go-github-com-alecthomas-repr
- (package
- (name "go-github-com-alecthomas-repr")
- (version "0.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/repr")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ikvl78dighkn87bxk6gki4wcz9f138n7kbqkagj5vbdb690yjkl"))))
- (build-system go-build-system)
- (arguments
- `(#:go ,go-1.18
- #:import-path "github.com/alecthomas/repr"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (home-page "https://github.com/alecthomas/repr/")
- (synopsis "Represent Go values in an almost direct form")
- (description "This package attempts to represent Go values in a form that
-can be used almost directly in Go source code.")
- (license license:expat)))
-
(define-public go-github-com-muesli-reflow-wordwrap
(package
(name "go-github-com-muesli-reflow-wordwrap")
t;mbakke@fastmail.com> 2020-03-05gnu: coq-mathcomp: Update home page URI.Björn Höfling * gnu/packages/coq.scm (coq-mathcomp)[home-page]: Update URI. 2020-01-07gnu: coq-stdpp: Reword comment.Brett Gilio * gnu/packages/coq.scm (coq-stdpp)[arguments]: Reword comment about tests being executed during build phase, to read more fluently. 2020-01-07gnu: coq-stdpp: Update to 1.2.1.Brett Gilio * gnu/packages/coq.scm (coq-stdpp): Update to 1.2.1. [arguments]: Remove redundant COQLIB variable. 2020-01-07gnu: coq-bignums: Fix comment spacing.Brett Gilio * gnu/packages/coq.scm (coq-bignums)[arguments]: Fix comment spacing after disabling test phase. 2020-01-07gnu: coq-bignums: Update to 8.10.0.Brett Gilio * gnu/packages/coq.scm (coq-bignums): Update to 8.10.0. 2020-01-06gnu: coq-equations: Update to 1.2.1.Brett Gilio * gnu/packages/coq.scm (coq-equations): Update to 1.2.1. [arguments]: Replace configure phase to run configure shell script. Remove redundant COQLIB. 2020-01-06gnu: coq-interval: Update to 3.4.1.Brett Gilio * gnu/packages/coq.scm (coq-interval): Update to 3.4.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake. 2020-01-06gnu: coq-coquelicot: Truncate home-page.Brett Gilio * gnu/packages/coq.scm (coq-coquelicot)[home-page]: Truncate home-page. 2020-01-06gnu: coq-coquelicot: Update to 3.0.3.Brett Gilio * gnu/packages/coq.scm (coq-coquelicot): Update to 3.0.3. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake. 2020-01-06gnu: coq-gappa: Use HTTPS home page URI.Brett Gilio * gnu/packages/coq.scm (coq-gappa)[home-page]: Use HTTPS URI. 2020-01-06gnu: coq-gappa: Update to 1.4.2.Brett Gilio * gnu/packages/coq.scm (coq-gappa): Update to 1.4.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake, as well as campl5 for parsing. [propagated-inputs]: coq-gabba now depends on coq-flocq. [arguments]: Temporarily disable check chase until error resolution is identified. 2020-01-06gnu: coq-flocq: Use HTTPS home page URI.Brett Gilio * gnu/packages/coq.scm (coq-flocq)[home-page]: Use HTTPS URI. 2020-01-06gnu: coq-flocq: Update to 3.2.0.Brett Gilio * gnu/packages/coq.scm (coq-flocq): Update to 3.2.0. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake. [arguments]: Add remove-failing-examples phase to work around union error. 2020-01-06gnu: coq: Reword several comments.Brett Gilio * gnu/packages/coq.scm (coq): Reword several comments to improve readability. 2020-01-06gnu: coq: Update to 8.10.2.Brett Gilio * gnu/packages/coq.scm (coq): Update to 8.10.2. [inputs]: Replace lablgtk with lablgtk3. [arguments]: Remove remove-lablgtk-references phase, as it no longer appears to be necessary. 2020-01-05gnu: coq-mathcomp: Update to 1.10.0.Brett Gilio * gnu/packages/coq.scm (coq-mathcomp): Update to 1.10.0. [arguments]: Modify comment about tests. Remove redundant setting of COQLIB environment variable. 2019-12-12gnu: coq: Split coqide.Julien Lepiller * gnu/packages/coq.scm (coq)[outputs]: Add "ide" output. 2019-11-25gnu: coq-bignums: Don't use unstable tarball.Efraim Flashner * gnu/pacakges/coq.scm (coq-bignums)[source]: Download using git-fetch.