aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-build.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 65a69cd954..8929aabdf2 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -643,7 +643,7 @@ terminals, as commonly found on Unix systems.")
(define-public go-golang-org-x-text
(package
(name "go-golang-org-x-text")
- (version "0.17.0")
+ (version "0.18.0")
(source
(origin
(method git-fetch)
@@ -652,7 +652,7 @@ terminals, as commonly found on Unix systems.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1jqvh4mmg3db2slh5z7fxdhkgazyld5l858rwnbpfxvfrw0k9w1h"))))
+ (base32 "1vxx2s1y1dmhiiv4cayrwf3ls4lbq22xkhl6xw3ls8jizribl5s9"))))
(build-system go-build-system)
(arguments
(list
>2020-09-19gremlin: Add 'set-file-runpath', 'file-runpath', and 'file-needed'....* guix/build/gremlin.scm (file-dynamic-info, file-runpath, file-needed): New procedures. (&missing-runpath-error, &runpath-too-long-error): New condition types. (set-file-runpath): New procedure. * tests/gremlin.scm ("set-file-runpath + file-runpath"): New test. Ludovic Courtès 2019-05-18gremlin: Adjust tests for foreign distros....Fixes <https://bugs.gnu.org/35775>. * tests/gremlin.scm ("elf-dynamic-info-needed, executable"): Expect only libguile and libc among NEEDED. ("strip-runpath"): Pass '--enable-new-dtags' to get RUNPATH, not RPATH. Ting-Wei Lan 2018-08-25Merge branch 'staging' into core-updatesMarius Bakke 2018-08-21gremlin: 'elf-dynamic-info-needed' test is no longer skipped....* tests/gremlin.scm (%guile-executable): Use /proc/self/exe instead of (command-line). For a while now, the first element of (command-line) was "./build-aux/test-driver.scm"; consequently the test was always skipped. Ludovic Courtès 2018-05-07gremlin: Add 'strip-runpath'....* guix/build/gremlin.scm (strip-runpath): New procedure. * tests/gremlin.scm (c-compiler): New variable. ("strip-runpath"): New test. Ludovic Courtès