aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/text-editors.scm38
1 files changed, 14 insertions, 24 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 2c5f5de719..ba3f1f56cc 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Tom Zander <tomz@freedommail.ch>
;;; Copyright © 2020 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2020 Maxime Devos <maximedevos@telenet.be>
@@ -308,7 +308,7 @@ bindings and many of the powerful features of GNU Emacs.")
(define-public jucipp
(package
(name "jucipp")
- (version "1.6.3")
+ (version "1.7.1")
(home-page "https://gitlab.com/cppit/jucipp")
(source (origin
(method git-fetch)
@@ -320,36 +320,28 @@ bindings and many of the powerful features of GNU Emacs.")
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1gy2xb5rm7q4zx9rl23h96b1i46fz27v25nklj50fvqp8ax2gxqy"))))
+ (base32 "0xyf1fa7jvxzvg1dxh5vc50fbwjjsar4fmlvbfhicdd1f8bhz1ii"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DBUILD_TESTING=ON"
-
- ;; These arguments are here to facilitate an "in-source"
- ;; build using "./build" instead of the default "../build".
- ;; The test suite expects that to be the case.
- "..")
- #:out-of-source? #f
+ `(#:configure-flags '("-DBUILD_TESTING=ON")
#:phases (modify-phases %standard-phases
- (add-before 'configure 'enter-build-directory
- (lambda _
- (mkdir "build")
- (chdir "build")
- #t))
-
(add-after 'unpack 'patch-tiny-process-library
(lambda _
(with-directory-excursion "lib/tiny-process-library"
(substitute* '("process_unix.cpp"
"tests/io_test.cpp")
- (("/bin/sh") (which "sh"))))
- #t))
+ (("/bin/sh") (which "sh"))))))
(add-after 'unpack 'disable-git-test
(lambda _
(substitute* "tests/CMakeLists.txt"
+ ;; Disable the CMake build test, as it does not test
+ ;; functionality of the package, and requires doing
+ ;; an "in-source" build.
+ (("add_test\\(cmake_build_test.*\\)")
+ "")
;; Disable the git test, as it requires the full checkout.
- (("add_test\\(git_test.*\\)") ""))
- #t))
+ (("add_test\\(git_test.*\\)")
+ ""))))
(add-before 'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
;; Tests do not expect HOME to be empty.
@@ -360,8 +352,7 @@ bindings and many of the powerful features of GNU Emacs.")
(display ":1"))
(setenv "DISPLAY" display)
(system (string-append xorg-server "/bin/Xvfb "
- display " &")))
- #t))
+ display " &")))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
;; The package needs GTK+ and GtkSourceView on XDG_DATA_DIRS
@@ -379,8 +370,7 @@ bindings and many of the powerful features of GNU Emacs.")
(map (lambda (pkg)
(string-append pkg "/share"))
(list out gtk+ gtksourceview shared-mime-info))
- ":"))))
- #t))))))
+ ":"))))))))))
(native-inputs
(list pkg-config xorg-server-for-tests))
(inputs
ring.scm (run-transmission-daemon-test): Likewise. * gnu/tests/ganeti.scm (run-ganeti-test): Likewise. * gnu/tests/guix.scm (run-guix-build-coordinator-test): Likewise. (run-guix-data-service-test): Likewise. * gnu/tests/ldap.scm (run-ldap-test): Likewise. * gnu/tests/linux-modules.scm (run-loadable-kernel-modules-test-base): Likewise. * gnu/tests/mail.scm (run-opensmtpd-test) (run-exim-test, run-dovecot-test, run-getmail-test): Likewise. * gnu/tests/messaging.scm (run-xmpp-test) (run-bitlbee-test, run-quassel-test): Likewise. * gnu/tests/monitoring.scm (run-prometheus-node-exporter-server-test) (run-zabbix-server-test): Likewise. * gnu/tests/networking.scm (run-inetd-test, run-openvswitch-test) (run-dhcpd-test, run-tor-test, run-iptables-test, run-ipfs-test): Likewise. * gnu/tests/nfs.scm (run-nfs-test) (run-nfs-server-test, run-nfs-root-fs-test): Likewise. * gnu/tests/package-management.scm (run-nix-test): Likewise. * gnu/tests/reconfigure.scm (run-switch-to-system-test) (run-upgrade-services-test, run-install-bootloader-test): Likewise. * gnu/tests/rsync.scm (run-rsync-test): Likewise. * gnu/tests/security-token.scm (run-pcscd-test): Likewise. * gnu/tests/singularity.scm (run-singularity-test): Likewise. * gnu/tests/ssh.scm (run-ssh-test): Likewise. * gnu/tests/telephony.scm (run-jami-test): Likewise. * gnu/tests/version-control.scm (run-cgit-test): Likewise. (run-git-http-test, run-gitolite-test, run-gitile-test): Likewise. * gnu/tests/virtualization.scm (run-libvirt-test, run-childhurd-test): Likewise. * gnu/tests/web.scm (run-webserver-test, run-php-fpm-test) (run-hpcguix-web-server-test, run-tailon-test, run-patchwork-test): Likewise. Ludovic Courtès 2021-04-12gnu: tests: Test basic funtionality of the IPFS service....It is tested whether the IPFS service listens at the gateway and API ports and whether it is possible to upload and download a bytevector. * gnu/tests/networking.scm (%ipfs-os): New variable. (run-ipfs-test): New procedure. (%test-ipfs): New system test. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos