aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 408064d9be..1818993399 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4880,3 +4880,31 @@ object to help create WSGI responses.")
(define-public python2-webob
(package-with-python2 python-webob))
+
+(define-public python-prettytable
+ (package
+ (name "python-prettytable")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/P/PrettyTable/"
+ "prettytable-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0diwsicwmiq2cpzpxri7cyl5fmsvicafw6nfqf6p6p322dji2g45"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://code.google.com/p/prettytable/")
+ (synopsis "Display tabular data in an ASCII table format")
+ (description
+ "A library designed to represent tabular data in visually appealing ASCII
+tables. PrettyTable allows for selection of which columns are to be printed,
+independent alignment of columns (left or right justified or centred) and
+printing of sub-tables by specifying a row range.")
+ (license bsd-3)))
+
+(define-public python2-prettytable
+ (package-with-python2 python-prettytable))
tle='2020-09-07 09:07:52 +0200'>2020-09-07gnu: Add python-pytest-toolbox....Vinicius Monego 2020-08-31gnu: python-nbval: Update to 0.9.6....Tobias Geerinckx-Rice 2020-08-09gnu: Add python-pytest-trio....Vinicius Monego 2020-08-01gnu: Add python-pytest-ordering....Vinicius Monego 2020-07-30gnu: Add python-mypy....Tanguy Le Carrour 2020-07-30gnu: Add python-mypy-extensions....Tanguy Le Carrour 2020-07-29gnu: Add python-nbval....Vinicius Monego 2020-07-25gnu: Add python-pytest-env....Vinicius Monego 2020-07-25gnu: Add python-covdefaults....Vinicius Monego 2020-07-25gnu: Add python-pytest-mpl....Vinicius Monego 2020-07-25gnu: Add python-pytest-remotedata....Vinicius Monego 2020-07-25gnu: Add python-pytest-openfiles....Vinicius Monego 2020-07-25gnu: Add python-pytest-filter-subpackage....Vinicius Monego 2020-07-25gnu: Add python-pytest-doctestplus....Vinicius Monego 2020-07-25gnu: Add python-pytest-arraydiff....Vinicius Monego 2020-07-21gnu: Add python-pytest-aiohttp....Efraim Flashner 2020-07-21gnu: Add python-pytest-services....Efraim Flashner 2020-07-21gnu: Add python-atpublic....Efraim Flashner 2020-07-20gnu: python-pytest-vcr: Fix integration with pytest-5....Efraim Flashner 2020-06-29gnu: python-pytest-flake8: Update to 1.0.6....Matthew Kraai 2020-06-22gnu: Add python-pytest-flask....Edouard Klein 2020-06-22gnu: Add python-pytest-benchmark....Edouard Klein 2020-05-26gnu: Add python-pytest-pycodestyle....Edouard Klein 2020-04-07gnu: python-coveralls: Update to 1.11.1....Marius Bakke 2020-03-15gnu: Add python-pytest-vcr....Efraim Flashner