aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 998de5dba6..545913e7ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7351,14 +7351,13 @@ running tests easier.")
(version "0.2")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/purcell/disable-mouse/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/disable-mouse.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0haqpq23r1wx04lsqrrg3p5visg9hx5i36dg55ab003wfsrlrzbc"))))
+ (base32 "1v1y5hf6k6ng7xsvgb27nh740d14m6l4krr0paccda8zgm4mw357"))))
(build-system emacs-build-system)
(home-page "https://github.com/purcell/disable-mouse")
(synopsis "Disable mouse commands globally")