aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8aa21c4fd6..6aaee38295 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14600,3 +14600,40 @@ modified nucleotides from nanopore sequencing data. Tombo also provides tools
for the analysis and visualization of raw nanopore signal.")
;; Some parts may be BSD-3-licensed.
(license license:mpl2.0)))
+
+(define-public python-pyvcf
+ (package
+ (name "python-pyvcf")
+ (version "0.6.8")
+ ;; Use git, because the PyPI tarballs lack test data.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jamescasbon/PyVCF.git")
+ ;; Latest release is not tagged.
+ (commit "bfcedb9bad1a14074ac4526ffdb610611e073810")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0c7lsssns3zp8fh2ibllzzra003srg9vbxqzmq6654akbzdb7lrf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-installed-tests
+ ;; Do not install test files.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (delete-file-recursively (string-append
+ (site-packages inputs outputs)
+ "vcf/test"))
+ #t)))))
+ (native-inputs `(("python-cython" ,python-cython)))
+ (propagated-inputs
+ `(("python-pysam" ,python-pysam)
+ ("python-rpy2" ,python-rpy2)))
+ (home-page "https://github.com/jamescasbon/PyVCF")
+ (synopsis "Variant Call Format parser for Python")
+ (description "This package provides a @acronym{VCF,Variant Call Format}
+parser for Python.")
+ (license license:expat)))
href='/guix/commit/gnu/packages/base.scm?id=4a13050b877f9058414f4b7633e423726e9bbb32'>gnu: binutils-gold: Inherit from 'binutils+documentation'....* gnu/packages/base.scm (binutils-gold): Inherit from BINUTILS+DOCUMENTATION instead of BINUTILS. Marius Bakke 2020-06-18gnu: coreutils: Update broken tests for the Hurd....* gnu/packages/base.scm (coreutils)[arguments]: When compiling for the Hurd, remove hanging "timeout-group" test. Remove tests "shred-passes", "l-chunk" and "stats" from XFAIL_TESTS, they pass now. Jan (janneke) Nieuwenhuizen 2020-05-26Merge branch 'master' into stagingMarius Bakke 2020-05-11gnu: proot: Fix test failures....The upgrade to Make 4.3 and Coreutils 8.30 introduced test failures that this commit addresses. * gnu/packages/base.scm (coreutils-8.30): New variable. * gnu/packages/linux.scm (proot)[native-inputs]: Add COREUTILS-8.30 and GNU-MAKE-4.2. Ludovic Courtès 2020-05-08Merge branch 'core-updates'Marius Bakke 2020-05-07gnu: glibc/hurd-headers: Cross-build fix for the Hurd....* gnu/packages/base.scm (glibc/hurd-headers)[native-inputs]: Add mig; when cross-building use 32-bit mig. Jan (janneke) Nieuwenhuizen 2020-04-26gnu: tzdata: Update to 2020a....* gnu/packages/base.scm (tzdata): Update to 2020a. Leo Famulari 2020-04-24gnu: Remove obsolete glibc-locales packages....* gnu/packages/base.scm (glibc-utf8-locales-2.27, glibc-locales-2.27): Remove variables. Marius Bakke 2020-04-24gnu: Update glibc locale compatibility packages for 2.29....* gnu/packages/base.scm (glibc-locales-2.28, glibc-utf8-locales-2.28): Rename to ... (glibc-locales-2.29, glibc-utf8-locales-2.29): ... this. Update to 2.29. Marius Bakke 2020-04-20gnu: tar: Disable troublesome tests on the Hurd....The sparse03.at test apparently freezes the Hurd; messages on the console: 165: listing sparse files bigger than 2^33 ext2fs: device:hd0s1: warning: bit already cleared for block 245780 ext2fs: device:hd0s1: warning: bit already cleared for block 245781 ext2fs: device:hd0s1: warning: bit already cleared for block 245782 ... ext2fs: BUG: unexpected fault on disk image ... err 0xa ext2fs: disk-pager.c:98: fault_handler: Assertion 'err' failed. the other tests just fail. * gnu/packages/base.scm (tar)[arguments]: When compiling for the Hurd, skip `sparse' and failing tests. Jan (janneke) Nieuwenhuizen 2020-04-20gnu: coreutils: Mark three more tests XFAIL on the Hurd....* gnu/packages/base.scm (coreutils)[arguments]: Add three more failing tests. Jan (janneke) Nieuwenhuizen 2020-04-01Revert "gnu: coreutils: Fix cross-compilation to i586-pc-gnu."...This reverts commit 67cbfeae30eb9b7c56145bf72582d71eea177370, which is not longer necessary now that the 'ld.so' linker script of the cross glibc contains "libhurduser.so libmachuser.so". Ludovic Courtès 2020-03-31gnu: coreutils: Fix cross-compilation to i586-pc-gnu....Until now cross-compilation would fail with: i586-pc-gnu-ld: src/copy.o: undefined reference to symbol 'file_chauthor' i586-pc-gnu-ld: /gnu/store/…-glibc-cross-i586-pc-gnu-2.29/lib/libhurduser.so.0.3: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status * gnu/packages/base.scm (coreutils)[arguments]: When 'hurd-target?', add #:configure-flags. Ludovic Courtès 2020-03-30gnu: coreutils: Typo: Use libcap only when supported....* gnu/packages/base.scm (coreutils)[inputs]: Typo: Use libcap only when supported. Jan Nieuwenhuizen 2020-03-29gnu: coreutils: Handle failing tests on Hurd....* gnu/base/coreutils.scm (coreutils)[arguments]: Use make-flags to mark some tests XFAIL_TESTS on the Hurd. Jan Nieuwenhuizen 2020-03-28gnu: OpenJDK: Build with GNU Make 4.2....* gnu/packages/base.scm (gnu-make-4.2): New public variable. * gnu/packages/java.scm (openjdk9, openjdk10, openjdk11, openjdk12)[native-inputs]: Add it. Marius Bakke 2020-03-26gnu: make: Support for the Hurd....* gnu/packages/base.scm (gnu-make): Use fork/exec rather than posix_spawn on the Hurd. Also, add __alloca linkage workaround. Jan Nieuwenhuizen 2020-03-24gnu: glibc: Add signal SA_SIGINFO support for the Hurd....* gnu/packages/patches/glibc-hurd-signal-sa-siginfo.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc): Use it. Jan Nieuwenhuizen 2020-03-24gnu: glibc: Add clock patches for the Hurd....* gnu/packages/patches/glibc-hurd-clock_t_centiseconds.patch: New file. * gnu/packages/patches/glibc-hurd-clock_gettime_monotonic.patch: New file. * gnu/local.mk (dist_patch_DATA): Update them. * gnu/packages/base.scm (glibc): Use them. Jan Nieuwenhuizen 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-21gnu: coreutils: Improve description....* gnu/packages/base.scm (coreutils): Improve description and state that there is no shell included. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Vitaliy Shatrov