aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/toolkits.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/toolkits.scm b/gnu/packages/toolkits.scm
index 1af10d83f4..46b7fd2cd6 100644
--- a/gnu/packages/toolkits.scm
+++ b/gnu/packages/toolkits.scm
@@ -168,4 +168,10 @@ standard operating system features.")
(file-name (git-file-name name version))
(sha256
(base32
- "02a7b05zrka20jhzag2jb4jl624i1m456bsv69jb9zgys2p9dv1n"))))))
+ "02a7b05zrka20jhzag2jb4jl624i1m456bsv69jb9zgys2p9dv1n"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments imgui)
+ ((#:make-flags flags ''())
+ ;; Remove the "-DImDrawIdx=unsigned int" make-flag as this breaks
+ ;; mangohud, the only user of this version.
+ #~(delete "-DImDrawIdx=unsigned int" #$flags))))))