aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-science.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index bbf80907e0..47d706904f 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1467,8 +1467,14 @@ multiple deep learning frameworks.")
"0cyldwchcrmbm1y7l1ry70kk8zdh7frxci3c6iwf4iyyj34dnra5"))))
(build-system pyproject-build-system)
(arguments
- ;; This needs a more recent version of python-hypothesis
- (list #:test-flags '(list "--ignore=xarray/tests/test_strategies.py")))
+ (list
+ #:test-flags
+ ;; This needs a more recent version of python-hypothesis
+ '(list "--ignore=xarray/tests/test_strategies.py"
+ ;; These are known to fail with Pandas 2
+ "-k"
+ (string-append "not test_datetime_conversion_warning"
+ " and not test_timedelta_conversion_warning"))))
(native-inputs
(list python-setuptools-scm python-pytest))
(propagated-inputs