aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/web-browsers.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5a83a4ef95..4e78c7555d 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Cage <cage-dev@twistfold.it>
+;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -477,7 +478,7 @@ interface.")
(define-public qutebrowser
(package
(name "qutebrowser")
- (version "1.14.1")
+ (version "2.0.2")
(source
(origin
(method url-fetch)
@@ -485,13 +486,14 @@ interface.")
"qutebrowser/releases/download/v" version "/"
"qutebrowser-" version ".tar.gz"))
(sha256
- (base32 "15l7jphy1qjsh6y6kd5mgkxsl6ymm9564g1yypa946jbyrgi8k2m"))))
+ (base32 "0fxkazz4ykmkiww27l92yr96hq00qn5vvjmknxcy4cl97d2pxa28"))))
(build-system python-build-system)
(native-inputs
`(("python-attrs" ,python-attrs))) ; for tests
(inputs
`(("python-colorama" ,python-colorama)
("python-cssutils" ,python-cssutils)
+ ("python-importlib-resources" ,python-importlib-resources)
("python-jinja2" ,python-jinja2)
("python-markupsafe" ,python-markupsafe)
("python-pygments" ,python-pygments)
e='2020-12-19 23:25:00 +0100'>2020-12-19tests: Check the build trace for hash mismatches on substitutes....Ludovic Courtès 2020-09-14tests: Remove one 'delete-paths' call in 'tests/store.scm'....Ludovic Courtès 2020-09-14daemon: Spawn 'guix authenticate' once for all....Ludovic Courtès 2020-09-11store: Test 'import-paths' with unauthorized and unsigned nar bundles....Ludovic Courtès 2020-08-28store: 'with-store' returns as many values as its body....Ludovic Courtès 2020-06-27daemon: Recognize SHA3 and BLAKE2s....Ludovic Courtès 2020-05-22packages: Introduce <content-hash> and use it in <origin>....Ludovic Courtès 2020-05-22tests: Test 'add-to-store' with several hash algorithms....Ludovic Courtès 2020-05-14store: 'mapm/accumulate-builds' preserves '%current-target-system'....Ludovic Courtès 2020-04-04store: 'with-store' doesn't close the store upon abort....Ludovic Courtès 2020-03-29store: Add 'map/accumulate-builds'....Ludovic Courtès 2020-03-22store: Add 'with-build-handler'....Ludovic Courtès 2019-10-16daemon: Make 'profiles/per-user' non-world-writable....Ludovic Courtès 2019-06-10store: 'build-things' accepts derivation/output pairs....Ludovic Courtès 2019-02-06daemon: Emit a 'build-succeeded' event in check mode....Ludovic Courtès 2019-01-21store: Rename '&nix-error' to '&store-error'....Ludovic Courtès 2019-01-09maint: Remove 'cond-expand' forms for Guile 2.0....Ludovic Courtès 2018-10-15daemon: Support multiplexed build output....Ludovic Courtès