aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-games.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/kde-games.scm b/gnu/packages/kde-games.scm
index dd3b615959..8844820cbe 100644
--- a/gnu/packages/kde-games.scm
+++ b/gnu/packages/kde-games.scm
@@ -1445,15 +1445,16 @@ This package is part of the KDE games module.")
(define-public knavalbattle
(package
(name "knavalbattle")
- (version "23.04.3")
+ (version "24.05.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/knavalbattle-" version ".tar.xz"))
- (sha256
- (base32 "1brj2dvymgpf74vbsrs2m81lxxfxsly9pafd13g8rkzdx3hn1n0q"))))
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/knavalbattle-" version ".tar.xz"))
+ (sha256
+ (base32 "0smr35f76hhy7gzla6q2ly9ip01ly3v33xhqq9dqpp144bs4vkab"))))
(build-system qt-build-system)
+ (arguments (list #:qtbase qtbase))
(native-inputs
(list extra-cmake-modules kdoctools))
(inputs
@@ -1469,8 +1470,7 @@ This package is part of the KDE games module.")
ktextwidgets
kxmlgui
libkdegames
- qtbase-5
- qtdeclarative-5))
+ qtdeclarative))
(home-page "https://apps.kde.org/knavalbattle/")
(synopsis "Battleship board game with built-in game server")
(description "KBattleship is a Battle Ship game for KDE.