aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/hurd.scm3
-rw-r--r--gnu/packages/patches/hurd-refcounts-assert.patch26
3 files changed, 29 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c98d3756fd..a7bd32453b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1558,6 +1558,7 @@ dist_patch_DATA = \
%D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hueplusplus-mbedtls.patch \
%D%/packages/patches/hurd-64bit.patch \
+ %D%/packages/patches/hurd-refcounts-assert.patch \
%D%/packages/patches/hurd-rumpdisk-no-hd.patch \
%D%/packages/patches/hurd-startup.patch \
%D%/packages/patches/hwloc-1-test-btrfs.patch \
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 63249b4ef7..61833219c4 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -316,7 +316,8 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(name "hurd")
(source (origin
(inherit (package-source hurd-headers))
- (patches (search-patches "hurd-rumpdisk-no-hd.patch"
+ (patches (search-patches "hurd-refcounts-assert.patch"
+ "hurd-rumpdisk-no-hd.patch"
"hurd-startup.patch"
"hurd-64bit.patch"))))
(version (package-version hurd-headers))
diff --git a/gnu/packages/patches/hurd-refcounts-assert.patch b/gnu/packages/patches/hurd-refcounts-assert.patch
new file mode 100644
index 0000000000..fe6d5e814f
--- /dev/null
+++ b/gnu/packages/patches/hurd-refcounts-assert.patch
@@ -0,0 +1,26 @@
+Upstream-status: Taken from <https://salsa.debian.org/hurd-team/hurd/-/blob/12f30157cc381a1987d5a2464a9c30092241aad1/debian/patches/libports-iterate-refcount.patch>.
+
+libports-iterate-refcount.patch>
+
+http://lists.gnu.org/archive/html/bug-hurd/2016-03/msg00034.html
+
+diff --git a/libports/bucket-iterate.c b/libports/bucket-iterate.c
+index b021b99..76dc3f7 100644
+--- a/libports/bucket-iterate.c
++++ b/libports/bucket-iterate.c
+@@ -58,7 +58,14 @@ _ports_bucket_class_iterate (struct hurd_ihash *ht,
+
+ if (class == 0 || pi->class == class)
+ {
+- refcounts_ref (&pi->refcounts, NULL);
++ struct references result;
++ refcounts_unsafe_ref (&pi->refcounts, &result);
++ if (result.hard == 1 && result.weak == 0)
++ {
++ /* This one is on its way out, skip it. */
++ refcounts_deref (&pi->refcounts, NULL);
++ continue;
++ }
+ p[n] = pi;
+ n++;
+ }