aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 647c64dcc7..425c273e0d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -129,7 +129,7 @@ interface to the Tk widget system.")
(define-public ecl
(package
(name "ecl")
- (version "16.1.2")
+ (version "16.1.3")
(source
(origin
(method url-fetch)
@@ -137,7 +137,7 @@ interface to the Tk widget system.")
"https://common-lisp.net/project/ecl/static/files/release/"
name "-" version ".tgz"))
(sha256
- (base32 "16ab8qs3awvdxy8xs8jy82v8r04x4wr70l9l2j45vgag18d2nj1d"))
+ (base32 "0m0j24w5d5a9dwwqyrg0d35c0nys16ijb4r0nyk87yp82v38b9bn"))
(modules '((guix build utils)))
(snippet
;; Add ecl-bundle-systems to 'default-system-source-registry'.
@@ -152,9 +152,6 @@ interface to the Tk widget system.")
("libffi" ,libffi)))
(arguments
'(#:tests? #t
- #:make-flags `(,(string-append "ECL="
- (assoc-ref %outputs "out")
- "/bin/ecl"))
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
@@ -182,7 +179,12 @@ interface to the Tk widget system.")
`("kernel-headers" ,@libraries)))
`("LIBRARY_PATH" suffix ,library-directories)
`("LD_LIBRARY_PATH" suffix ,library-directories)))))
- (add-after 'wrap 'check (assoc-ref %standard-phases 'check)))))
+ (add-after 'wrap 'check (assoc-ref %standard-phases 'check))
+ (add-before 'check 'fix-path-to-ecl
+ (lambda _
+ (substitute* "build/tests/Makefile"
+ (("\\$\\{exec_prefix\\}/") ""))
+ #t)))))
(native-search-paths
(list (search-path-specification
(variable "XDG_DATA_DIRS")
Milosavljevic 2021-02-05rust: Cleanup commit to prepare for new bootstrap....Maxim Cournoyer 2021-01-10Merge branch 'master' into stagingEfraim Flashner 2021-01-02gnu: Add Rust 1.49....Jakub Kądziołka 2021-01-02gnu: Add Rust 1.48....Matthew Kraai 2021-01-02gnu: Add Rust 1.47....Matthew Kraai 2020-12-29Merge branch 'ungrafting' into stagingMarius Bakke 2020-12-29gnu: rust: Remove "i686-linux" from supported systems....Mathieu Othacehe 2020-12-13gnu: rust-1.46: Add rustfmt output...Matthew Kraai 2020-10-05Merge branch 'master' into stagingGuillaume Le Vaillant 2020-09-25gnu: rust: Fix install phase for non-x86_64 platforms....Pierre Langlois 2020-09-23Merge branch 'staging' into wip-lispGuillaume Le Vaillant 2020-09-23gnu: Fix typoes in package descriptions....Tobias Geerinckx-Rice 2020-09-07gnu: Add Rust 1.46....Jakub Kądziołka 2020-09-05Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner 2020-08-03gnu: rust-1.45: Update to 1.45.2....Jakub Kądziołka 2020-07-30gnu: rust-1.45: Update to 1.45.1....Jakub Kądziołka 2020-07-29gnu: rust-1.26: Build with newer openssl....Efraim Flashner 2020-07-29gnu: rust-1.38: Build with llvm-9....Efraim Flashner 2020-07-29gnu: rust-1.28: Remove disable-cargo-test-for-nightly-channel phase....Efraim Flashner 2020-07-27gnu: rust: Update to 1.45....Efraim Flashner 2020-07-24Merge branch 'master' into stagingMarius Bakke