aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 636221af35..2906c50646 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -466,6 +466,13 @@ an interpreter, a compiler, a debugger, and much more.")
(srfi srfi-1))
#:phases
(modify-phases %standard-phases
+ ,@(if (target-arm32?)
+ ;; TODO: Move to snippet in staging.
+ `((add-after 'unpack 'dont-force-armv5
+ (lambda _
+ (substitute* "src/runtime/Config.arm-linux"
+ (("-march=armv5") "")))))
+ '())
(delete 'configure)
(add-after 'unpack 'fix-build-id
;; One of the build scripts makes a build id using the current date.