aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mpi.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 97471d56e9..f208957f93 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -548,3 +548,28 @@ Gigabit Ethernet, InfiniBand, Myrinet, Quadrics), and proprietary high-end
computing systems (Blue Gene, Cray). It enables research in MPI through a
modular framework for other derived implementations.")
(license license:bsd-2)))
+
+(define-public mpich-ofi
+ (package/inherit mpich
+ (name "mpich-ofi")
+ (inputs (modify-inputs (package-inputs mpich)
+ (delete ucx)
+ (append libfabric)
+ (append rdma-core)
+ (append psm2)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments mpich)
+ ((#:configure-flags flags)
+ #~(list "--disable-silent-rules" ;let's see what's happening
+ "--enable-debuginfo"
+ "--with-device=ch4:ofi"
+
+ (string-append "--with-hwloc-prefix="
+ #$(this-package-input "hwloc"))
+
+ (string-append "--with-libfabric="
+ #$(this-package-input "libfabric"))))
+ ((#:phases phases
+ '%standard-phases)
+ phases)))
+ (synopsis "Implementation of the Message Passing Interface (MPI) for OmniPath")))